11

My laptop's screen is far too bright at night, even if I set it to minimum brightness. I know that it is capable of being dimmer, because Windows will dim it further if I leave it idle. However, I can't figure out how to dim it lower to minimum on Ubuntu. Is there a way?

I've looked at this question, but it's talking about Windows.

2
  • If the back-light is set to the minimum, then that is all you can do with it. Try adjusting the brightness, contrast, and gamma of the video-card with something like xgamma or other program. – Synetech Jan 3 '14 at 5:09
  • This solution works best for me – Pavel Mar 27 '17 at 22:57
10

Here is a link specifically addressing setting screen brightness below the minimum:

Decrease Backlight Below Minimum – Ask Ubuntu

  1. Open Terminal

  2. Enter the following command:

    cat /sys/class/backlight/intel_backlight/brightness
    
  3. Write down the resulting value (12421 in my case)

  4. Divide value by 6 and write it down (2070 in my case)

  5. Enter the following in the terminal, replacing 2070 with your value:

    sudo su -c "echo 2070 >/sys/class/backlight/intel_backlight/brightness"
    
  6. Close Terminal

  7. For future usage of the last command, open Terminal, press Ctrl and R together, start typing brightness. When the last command appears, just press Enter.

It works for me on a Samsung NC110 with Ubuntu 12.04.

6
  • 1
    That gives better control within the standard range. I want to go outside the standard range. – cpast Mar 4 '13 at 6:05
  • For me, this dimmed the screen well past the minimum. :) (Lenovo Y50) – Chris Cooper Dec 19 '14 at 4:31
  • Also worked great with 14.04 on acer E15. +1 – davewoodhall Mar 6 '15 at 5:01
  • I get cat: /sys/class/backlight/intel_backlight/brightness: No such file or directory from the first command. Is it because I have a discrete video card (GTX460M) in my laptop? (I'm on Ubuntu 14.04 LTS) – Borgleader Jul 8 '15 at 1:13
  • @Borgleader Yeah, just look in /sys/class/backlight for the folder corresponding to your video card. – Azmisov Sep 19 '15 at 7:21
4

you can also use "xgamma -gamma 0.5" command to decrease the intensity of RGB colors. See xgamma usage by using command "man xgamma". For my intel display the gamma brightness varies from 0 to 10(including decimal values).

1
  • 1
    This does not dim white color – MainActivity Oct 16 '19 at 7:12
2

TLDR: Settings > Accessibility > Zoom

Here is a last resort for anyone who tried the above and was unsuccessful (and made it here almost a decade after the initial question).

My setup: Gnome, Wayland, Fedora 33, Dell XPS 15 9500

I'm not entirely up to date with Ubuntu, but if you're running Gnome and Wayland this might work for you.

You should be able to find in the Zoom feature via Settings > Accessibility > “Seeing” > Zoom. Here you should be able to modify brightness, contrast, color according to your preferences. Set magnification to 1.0 (unless you want your focus to follow the mouse around). If you run into weird lingering visual artifacts from the mouse you can enable the crosshair and customize the color to be transparent (I also have thickness and length set to the minimum, and unchecked the “overlaps mouse cursor”, although I’m not sure whether these settings matter).

Lastly, for convenience and easy toggling, via Settings > Keyboard Shortcuts there should be an option for “Turn zoom on or off” which you can map to an appropriate key binding (mine is set to “Shift + Monitor brightness down”). YMMV!

Credit goes to Bastien: https://bugzilla.gnome.org/show_bug.cgi?id=741224#c42

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.