I need to run IE 10 in 32-bit mode on 64-bit Windows 7 Enterprise N.

When I run IE 10 from "C:\Program Files (x86)\Internet Explorer" I can see in task manager that I have only one process "iexplorer.exe" and no process "iexplorer.exe *32".

I have an application with an ActiveX that is supported only on 32-bit, and the application can't be loaded on 64-bit mode.

Is there a way I can force IE10 to run in 32-bit mode?

3 Answers 3


This occurs because the TabProcGrowth registry entry is set to 0, meaning tabs are set to run in the same process as the manager process (64-bit), rather than opening a new process for each tab (32-bit). You can fix this by changing the registry entry here:

HKEY_CURRENT_USER\Software\Microsoft\Internet Explorer\Main\TabProcGrowth or HKEY_LOCAL_MACHINE\Software\Microsoft\Internet Explorer\Main\TabProcGrowth

Set it to something greater than 0, restart IE, and you should see normal behavior resume (and your add-ons should work again). More info in this Microsoft KB article.

  • The referenced KB article only applies to Windows 8, whereas the OP is asking about Windows 7. I'm also running IE10 on 64-bit Windows 7, and don't see that registry key at the specified path.
    – Indrek
    Mar 14, 2013 at 19:27
  • While the KB article does mention Windows 8, it applies to Windows 7, as well. I am running Win7 64bit, and I just did it. Try looking again - the TabProcGrowth is a DWORD entry in the "Main" folder - I realize that my path above may have made it seem like 'TabProcGrowth' is a folder, when in fact it is the entry. Mar 14, 2013 at 19:39
  • 1
    Nope, still can't see it, neither as a key (folder) nor a value (entry). IE10 on Windows 7 64-bit. Anyway, doesn't matter because I'm not having a problem with this. Hopefully the OP will check out your answer and verify whether or not it works for them.
    – Indrek
    Mar 14, 2013 at 21:28
  • 2
    Thanks! It helped. I could find this registry entry only on "Windows 7 Enterprise N" where I had the problem. On "Windows 7 Enterprise" the registry entry doesn't exists at all and every thing works correctly.
    – Keren Haas
    Mar 17, 2013 at 8:56

You need to read the Understanding Enhanced Protected Mode article to understand Internet Explorer’s Process Model and Bitness:

For the past several releases, Internet Explorer has sported a multi-process architecture, where the “Frame” or “Manager” process runs at Medium Integrity and the “Tab” or “Content” processes run at either Low Integrity (Protected Mode) or Medium Integrity (for Zones where Protected Mode is disabled, like Intranet sites). All HTML content and ActiveX controls run in the Content Process. Even toolbars, which visually appear as if they’re in the Manager Process, really run down in a Content Process.

For IE10, we’ve changed IE such that Manager Processes always run as 64bit processes when running on a 64bit processor running a 64bit version of Windows. ... In support of this change, the various registry points that point to Internet Explorer have been updated to point to C:\Program Files\Internet Explorer\iexplore.exe. If you manually invoke C:\Program Files (x86)\Internet Explorer\iexplore.exe, that 32bit process will simply launch the 64bit version of iexplore.exe (with the appropriate command line parameters) before exiting.

In Internet Explorer on the Desktop, by default, Content Processes remain at 32bit by default for compatibility with 32bit ActiveX controls, Toolbars, BHOs, etc. Even when you directly launch the 64bit iexplore.exe executable, you will still have a 64bit Manager Process that hosts only 32bit Content Processes. If you want to enable 64bit Content Processes for the Desktop, you must tick the Enable Enhanced Protected Mode option in the Security section of Internet Explorer’s Tools > Internet Options > Advanced tab. When this option is enabled, all Content Processes that are running in Protected Mode (e.g. Internet Zone and Restricted Zone, by default) will begin to use 64bit Content Processes.

In the upcoming Internet Explorer 10 on Windows 7 and Windows Server 2008R2, the only thing that enabling Enhanced Protected Mode does is turn on 64bit Content Processes.

So irrespective of whether I launch 32 or 64-bit IE10, as long as Enhanced Protected Mode is disabled, I can load 32-bit ActiveX controls or Content Processes just fine. This is what I see in Task Manager on Win7 x64 when a 32-bit ActiveX control is loaded in 32-bit IE10:


You should confirm that Tools / ActiveX Filtering is not turned on, and if that doesn't help, review the security settings for your current zone.

  • "Enhanced Protected Mode" is disabled, "Tools / ActiveX Filtering" isn't turned on, but still I have only one process in task manager and the activeX isn't loaded. Any more ideas ?
    – Keren Haas
    Mar 6, 2013 at 7:14
  • Have you tried a browser reset yet? Other than that, I don't know why the 32-bit process is not getting launched in your case. Can you test on another Win7 x64 PC with IE10?
    – Karan
    Mar 6, 2013 at 7:16
  • I tried to reset the browser many times. We have two machines with the same problem and one that is ok, but I can't find the difference between them.
    – Keren Haas
    Mar 6, 2013 at 8:03

In prior versions of 64-bit Windows there were two versions of Internet Explorer that came as part of the operating system. One was the regular 32-bit version as well as a native 64-bit version.

An ongoing problem with 64-bit Internet Explorer is that plugins designed for the 32-bit version aren’t compatible with it but you still might fancy using it on Windows 8.

So, here’s how you enable it:

Open Internet Explorer 10 on the desktop, Click the Settings cog up the top right corner of the window, Click the Advanced tab, Scroll down until you see Enable Enhanced Protected Mode* and tick the box next to it, Click OK, Restart Internet Explorer.


source: http://mingersoft.com/blog/2012/09/switch-between-32-bit-and-64-bit-internet-explorer-10-in-windows-8/

  • 1
    Already tried that and it didn't help. According to that post, the checkbox shouldn't be checked if I need 32-bit. Moreover, it is relevant to Windows 8 and not 7.
    – Keren Haas
    Mar 5, 2013 at 12:21

Not the answer you're looking for? Browse other questions tagged or ask your own question.