I have admin privilege on my office computer (running RHEL 6) which is connected in a network. I was trying to install development tools using the command: sudo yum groupinstall "Development Tools" but I got an error message saying:

Updating certificate-based repositories.
There was an error communicating with RHN.
RHN Satellite or RHN Classic support will be disabled.

Error Message:
 Please run rhn_register as root on this client
 Error Class Code: 9
 Error Class Info: Invalid System Credentials.

I tried to run rhn_register, it said "It appears this system has already been registered for software updates".

What is the problem actually?


In order to install new updates with yum you need to register your system with RHN(Red Hat Network) which is a paid service.

Pay attention to these error lines:

There was an error communicating with RHN.
Error Class Info: Invalid System Credentials.

Since it says that your system was previously registered (depending on how your system was deployed) it might have preserved the reg file /etc/sysconfig/rhn/systemid, you can remove it and try rhn_register. You will be challenged for username and password when registering a system with RHN. If this still doesn't work than you have bigger issues related to networking.

Ref: rhn

| improve this answer | |
  • When I followed your instruction and tried to register my computer on RHN afresh, it said something like all channels have been exhausted. – rivu Mar 6 '13 at 22:26
  • it means you are out of entitlements. you can reuse them or get pay for more. – Dejan Mar 7 '13 at 15:41
  • Adding to Dejan's Answer: You open a new case at [Red Hat Customer Portal][1] and post your issue there. You should get better help in your case. [1]: access.redhat.com/home – TPS May 5 '14 at 6:19

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.