I have a 900GB HDD, but for some reason it will only allow me to shrink like 2500MB of it. In the past, I could shrink to my desired size, but for some reason it is giving me a problem now. I have tried defragging it with PerfectDisk, but I actually think doing that made it even smaller. I have also tried using cmd diskpart but that fails too. Heres a pic:

Shrink C

Thanks for any help!

  • 2
    There's an explanation in the middle of the box in the link you pasted that tells you what causes this and what to do about it. – David Schwartz Mar 6 '13 at 10:39
  • You are attempting to shrink a volume with files that are unable to be moved. You will need to get rid of those files ( its likely a page file ) before you will be able to do this. – Ramhound Mar 6 '13 at 12:44
  • 1
    @Ramhound This can also be caused by 'unmovable' files, such as file system metadata. I believe the MFT mirror is created in the middle of the partition by default. The normal solution is to perform an offline resize using a tool that can move files and metadata, such as the Linux parted utility (often used with the gparted graphical interface). – Bob Mar 6 '13 at 13:11
  • 1
    @Ramhound I am aware that they are using Windows. In my previous comment, I used a popular nix-based tool *as an example, though there are other methods. If desired, it is possible to use a Linux Live CD independent of the installed OS - Parted Magic is designed specifically for this purpose. It's important to note, however, that resizing a partition in this manner can lead to a loss of data. – Bob Mar 6 '13 at 13:48
  • 8
    Possible duplicate of How to shrink Windows 7 boot partition with unmovable files – fixer1234 May 22 '16 at 18:26

The main reason for not being able to shrink the disk are that there are unmovable files on the disk at the time of trying to shrink the volume (as your screenshot says).

The most common "unmoveable" files are files which are locked during normal computer operation such as virtual memory/pagefile/system restore files as well as a few other files which may be open, but not running "in memory"

Having come across this myself previously on both server and desktop operating systems - I can say the most likely culprit is the pagefile.

To fix this:

  1. Right-click Computer
  2. Select Properties
  3. Select Advanced system settings
  4. Select the Advanced tab and then the Performance radio button
  5. Select the Change box under Virtual memory
  6. Un-check Automatically manage paging file size for all drives
  7. Select No paging file, and click the Set button
  8. Select OK to allow and restart.

Once your machine has rebooted and you know you have no page file (check at the root of C: with hidden and system files showing) - try a defrag and then try shrinking the volume again.

Don't forget to reset your pagefile back to its original size afterwards! Failure to do so will potentially cause significant performance issues with any machine.

Hope this helps,

The answer here worked for me: How to shrink Windows 7 boot partition with unmovable files

Turn off Virtual Memory and System Restore, then run your shrink, then turn them back on again.

  • 1
    Fazer's answer didn't work for me. Had to also disable and delete system restore as mentioned here – Ryall Oct 16 at 14:20

Your Answer

 

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.