I have a laptop with an Aptio BIOS and OEM Windows 8. My hard disk drive is defect, but the warranty has expired. So I bought a new hard disk drive, built it in and now I'm trying to install Windows 8 from an original Windows 8 setup disc. Every time I start the laptop, the BIOS setup comes up. Now I achieved the boot menu, but the only boot option is:

UEFI: IP4 Realtek Ethernet Controller

How can I boot from the setup disc?

After activating the Compatibility Support Module (CSM), the setup still comes up, and I'm still unable to boot from the CD.

  • 1
    See if there's an option to turn off secure boot. If that doesn't help, see if you can enable the "legacy BIOS" or "Compatibility Support Module (CSM)". – Karan Mar 7 '13 at 1:49
  • after activating csm the setup still comes up – Paedow Mar 9 '13 at 16:15
  • 1
    Seems to me like boot from CD on bios should be an easy thing...but nope, it's buried. +1 – Josiah Oct 8 '15 at 19:15

After doing some research and trying to figure this out, I found an article online that mentioned holding ESC while using the power button to turn on the computer. After further testing I figured out that I needed to have the Secure Boot option in the BIOS disabled or else I got a security error when I tried to boot to the USB device. I changed this by going to the Security menu and disabling the "Secure Boot Control" option.

I also had a setting called "Launch CSM" under the boot menu which I had to enable (did not enable "Launch PXE OpROM"). With the secure boot option disabled and launch CSM enabled, I was able to hold ESC while powering on the laptop and boot into my USB device. Doing this gave me a menu at boot up where I could choose what to boot into. I chose the option: "UEFI: General USB Flash Disk 1.0" (I had created Macrium Reflect rescue media and during the setup checked the box "Enable multiboot MBR/UEFI USB support", so I am not sure if you would still want to choose this otherwise).

I was working on an ASUS laptop (SonicMaster I think) using the Aptio Setup Utility - Copyright (C) 2012 American Megatrends, Inc. If you are using a different BIOS the steps for this may not be the same, but hopefully there is enough information here for you to make this work on your computer.

I also noticed that after getting this to work using the above method, I got some extra options in the BIOS that were previously not there. This included extra boot options (boot menu) and extra boot override options (save & exit) menu. The new boot override option "UEFI: General USB Flash Disk 1.0" worked great after the steps above.

Before I had found this option, I had also seen online where people had mentioned holding Shift while clicking the restart button under Windows 8 to get a menu option to boot to a device. [https://askleo.com/how_do_i_boot_from_cddvdusb_in_windows_8/]. This didn't work for me, but you may want to try this first to see if it works for you.

  • 1
    This totally worked on an Asus K55A to allow me to boot to the DVD. To reboot from Windows into the BIOS screen to change things, I just held the "SHIFT" key when rebooting windows, and it gave me the option to enter the "UEFI" mode somewhere in that menu, which means boot to the Bios! – Brad Parks Jan 5 '16 at 22:51

I just got a "new" Notebook (sold here in Austria by "Hofer") and came to know that the BIOS changed and is different from previous ones: Fewer possibilities to change and in the boot order option also only:

  • UEFI: IP4 Realtek
  • UEFI: IP6 Realtek

to choose from.

In the same menu there is a select box: "Boot from Windows 8" which is activated.

After changing this selection to "other system" and saving/reboot I was able to get into the F7 select boot device (F7 or F9 whatever suites your notebook) and start from DVD or hard disk drive. Selecting the hard disk drive to boot from I was astonished: No Windows 8 coming up, so I had to go back to the BIOS again and change back to "Boot from Windows 8".


You should disable "fastboot mode" and restart before being able to see "Boot device priority"/"Boot override": You should then see boot priority options.

If you find other problems booting, try setting "secure boot mode" to CMS.

Source: Aptio BIOS USB Boot

  • Welcome to Super User! Generally we like answers on the site to be able to stand on their own - Links are great, but if that link ever breaks the answer should have enough information to still be helpful. Please consider editing your answer to include more detail. See the FAQ for more info. – slm Apr 15 '13 at 14:02

protected by bwDraco May 6 '15 at 20:38

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.