I am looking to use OpenVPN straight from the terminal instead of using a gui such as tunnelblick - but am encountering a couple of problems. I have tested my config file and it works fine so it is not the config fault.

The command I am running is

./openvpn connection.ovpn

The error message that I am getting is

Wed Mar  6 13:22:57 2013 us=528389 Cannot allocate TUN/TAP dev dynamically
Wed Mar  6 13:22:57 2013 us=528401 Exiting due to fatal error

Which seems to be implying that a tun/tap kext cannot be found. I have tried to run the command

sudo kextload tun.kext

immediately prior to this and it seemed to load fine but I still get the above error. I am using the 64-bit tun.kext from the TunnelBlick project so it should not be a problem with the kext itself. Any ideas?

  • Years later... I don't think OpenVPN has a command-line option any more?
    – MarkHu
    May 27, 2021 at 16:58

1 Answer 1


It turns out that the above problem was quite simple. OpenVPN has to be run with administrative privileges. So, instead run

sudo ./openvpn connection.ovpn
  • 3
    Even with root, it still says Thu Oct 17 14:49:45 2013 Cannot allocate TUN/TAP dev dynamically, Thu Oct 17 14:49:45 2013 Exiting due to fatal error... Any idea? Oct 17, 2013 at 12:50
  • @bibstha Do you have a Tun/Tap kext installed on the machine?
    – xizor
    Oct 17, 2013 at 12:56
  • Oops no, I didn't execute the "sudo kextload tun.kest" part. However I could successfully login using tunnelblick without tun/pta driver. Oct 19, 2013 at 13:01

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .