5

I want my pivot table to auto update/refresh when I add more data to the table that I am generating the pivot table from. In that case I have selected the entire worksheet to generate the pivot table. Because I have blank columns and rows in my worksheet, a column and row titles "blank" are automatically added to my pivot table.

How can I keep addding data to my chart that will automatically refresh my pivot table and not have a "blank" column or row?

  • What exactly are you creating the pivot table with? Excel for Mac? Which version? – Karan Mar 7 '13 at 3:47
4

Rather than using the entire worksheet as the source of the pivot table data, use a dynamic range. This will expand and contract as you add and remove data. You will just need to refresh your pivot table each time you change the data. This assumes that you have all your data at the top of the worksheet and are adding new data to the bottom, so the range will expand downwards.

In Excel 2010, go to the Formulas tab and select Name Manager. Create a New range, call it something like 'all_data' (spaces aren't allowed in the name). In the 'Refers to' box, use the following formula, adapted for your own data:

=OFFSET(Source!$A$1,0,0,COUNTA(Source!$A:$A),1)

To break this down:

Source!$A$1 reference - this is usually the top left cell of your data (usually the first cell in the header row)

0,0 rows,cols - you don't want to offset from the reference so these are both zero

COUNTA(Source!$A:$A) height - this will count the number of non-blank cells in column A - change this to a column that will always have an entry for each row, for example the column that has an ID for each row

1 width - this is the number of columns across your data is - e.g. if you have columns A to E filled then this number would be 5

When you insert a new pivot table, type the named range (all_data) in the 'Table/Range' box, rather than selecting the entire worksheet.

2

Simply unselect the "Blank" option in the data. Then it will not appear in the pivot. When you update this should be remembered I think.

2

The "Row Labels" column has a Filter drop-down menu. Deselect "blanks" from the filter list.

  • I would like to add that you have to select the field on top of this drop-down menu in case it's in an other column. – Cerveser Sep 18 '19 at 17:22
0

Just to clarify, you will need to make sure that the field settings allow for new items to be added to manual filter. Click on the data label in the pivottable field list and select field settings

0

If you select the carrot button on the row label and unselect (blank) on the filter, you automatically unselect (Select All) which basically freezes the filters in place so new data will not be added to the pivot table if it has a new value that isn't already selected.

A very simple work around is to click the carrot button, hover over 'Label Filters', go to 'Does Not Equal...' and then type in (blank).

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.