14

When javascript is off (NoScript), a site redirects me and i can't get back to the page i came to.

<noscript><meta http-equiv="refresh" content="0; URL=/badbrowser.php"></noscript> 

How to forbid such redirect but let me follow it manually (like NoRedirect does), or at least make it leave an entry in page history?

NoRedirect doesn't handle this situation.

Information for other browsers is welcome too.

8
  • What browser are you using? What OS? What other add ons do you have? Mar 6, 2013 at 19:50
  • Browser=firefox, the rest doesn't matter, does it? Mar 6, 2013 at 19:51
  • Kinda does, as some add ons also affect scripts, more so then just NoScript Mar 6, 2013 at 19:53
  • 1
    This is standard behaviour of browsers to follow this kind of redirect and leave no trace in page history. Now, how to change that? Mar 6, 2013 at 20:20
  • 1
    The fact that web standards are made to mistreat users doesn't mean that all browsers must unconditionally comply with the ugly parts of the standard. The noscript tag is a big part of a problem, we need to deal with it. Unfortunately both answers to this question do not work with the recent version of Firefox. Hopefully someone finds how to do this. Feb 9, 2018 at 20:54

5 Answers 5

8

In firefox, go to about:config and search for "refresh". Then, just set accessibility.blockautorefresh to true and you're done.

4
  • 1
    Doesn't work in Firefox 58.0.2. Feb 9, 2018 at 20:47
  • @SargeBorsch My Firefox 60 does have that option, and it is the third option from top after accessability.AOM.enabled and accessibility.accesskeycausesactivation. No need to search.
    – neverMind9
    Jul 8, 2018 at 10:18
  • The option is present, but it does nothing. I have enabled it, checked what seems to be overall accessibility toggle ("Allow accessibility services to access browser" in Firefox settings), and it still does not block meta-equiv redirects. Don't waste your time with this option. Dec 1, 2018 at 12:19
  • Worked for me on Firefox Quantum 66.0.3 (64-bit) on Windows. Thanks.
    – Ryan
    Apr 16, 2019 at 19:32
6

NoScript → Options → Advanced → Untrusted → 'Forbid META redirections inside <noscript> elements'

1
  • 3
    There is no such option in the new NoScript which is compatible with FF 57+ Feb 10, 2018 at 7:41
0

A really quick solution:

open Scratchpad (Shift+F4)
switch Environment to Browser
type gBrowser.webNavigation.allowMetaRedirects = false
Execute/Run

Congratulations, now the current tab (and only that tab) will be immune to meta redirects.

1
  • 1
    Doesn't work in Firefox 58.0.2. It only produces an exception: "Cannot modify properties of a WrappedNative" Feb 9, 2018 at 20:52
0

I came to this question looking for a solution in uBlock Origin. In the filters list, you can put a global disable for this type of noscript meta refresh infinite loop shenanigans:

*##^noscript > meta[http-equiv="refresh"]

This disables all meta refresh directives inside noscript tags on all sites.

-1

In Internet Explorer, “Tools” –> “Internet Options” brings up the “Internet Options” window.  Go to the “Security” tab and click on “Custom Level”; a “Security Settings” window will appear.  It has a bunch of options (settings) in groups; the groups are sorted alphabetically, and the options are sorted within the groups.  In the “Miscellaneous” group (about halfway down) there is an “Allow META REFRESH” option (which can be set to “Disable” or “Enable”).

2
  • Is it completely disabled or can i enable single redirects manually? Mar 7, 2013 at 21:04
  • Well, of course, you can always “View Source”, copy the URL and paste it into the address bar. I don’t know of anything better than that; in fact, AFAIK, it doesn’t even tell you that there is a META REFRESH on the current page. Mar 7, 2013 at 21:07

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .