Currently I have 3 network drives I mount each time i restart my system. The command I use is:

sudo mount -t cifs // /media/Ares -o user=USER,password=***
sudo mount -t cifs // /media/Athena -o user=USER,password=***
sudo mount -t cifs // /media/Pluto -o user=USER,password=***

I would love to add these puppies over to fstab so I did some googling and came up with this gem: http://www.cyberciti.biz/faq/configure-a-system-to-automount-a-samba-share-with-etcfstab/ the issue is my system refuses to see smbfs as a valid type, and boot fails. What is the correct way to mount samba shares via fstab as cifs?

I had tried:

// /media/Pluto      cifs   username=USER,password=** 0 0

but this also resulted in a failed boot.


I guess i could put them all in a bash script, and run the bash script on system boot....but that seems like a crappy work around

1 Answer 1


I have a wiki page which deals in details about Samba mount, either using the smbfs or cifs file system type.

I do not see any error in what you tried. Perhaps you could try to use smbfs instead of cifs, take care that the options might be slightly different! smbfs is the deprecated SMB filesystem in the Kernel, it is still here around for historical reason. You should keep on using cifs which is the supported filesystem.

In addition, I recommend to use the credentials option, so you can put the password in a safer place than fstab which is often world readable!

Finally, you do not need to reboot to test your /etc/fstab changes. Simply umount your share (if it is mounted) and mount it again by typing:

mount /media/PLUTO
  • ** "world" readable, not "word" readable... some people just might get confused...
    – kalaracey
    Mar 13, 2013 at 13:21
  • @kalaracey thanks for spotting the typo, this is now corrected.
    – Huygens
    Mar 13, 2013 at 13:37

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.