17

I travel to multiple offices (and multiple desks in those offices), and whenever possible I plug an external monitor into my laptop. Whenever I plug in a monitor I haven't used before, Windows defaults to "Duplicate these displays" - which messes up the arrangement of icons on my desktop if the external monitor is a different shape from my laptop's monitor. I then select "Extend these displays", and my laptop screen returns to its original shape - but my icons don't go back to their original arrangement. Grrrrr. Fast-forward a few days or weeks; I've got my icons arranged so I can find stuff again - then I go to a new office and it starts all over again. I'm tired of this.

Is it possible to make "Extend these displays" the default behavior?

I'm using Windows 8 x64 Home Premium, but I had the same complaint under Windows 7 x64 Ultimate. (Prior to that, I hadn't discovered the joy of dual displays. Ah, the time I wasted...)

3
  • check out a program called display fusion, its not terribly expensive, and it takes the hassle out of secondary displays.
    – MDT Guy
    Dec 17, 2013 at 17:28
  • Facing the same irritation. Wondering if any solution has been found meanwhile? Using windows 8.1 Enterprise.
    – Venkat
    Jul 23, 2015 at 7:37
  • @Venkat - No solution that I'm aware of. Fortunately I've already used monitors at most of my clients, so I don't run into this very often anymore... but I dread the next time I get a new laptop and have to start all over.
    – MT_Head
    Jul 23, 2015 at 7:46

5 Answers 5

3

Also looking for a permanent configuration setting... In the meantime I'm using Iconoid (free) - it lets you save the icon positions for different screen resolutions, and you can set it to automatically restore positions when a screen is plugged in (new resolution is set)

2
  • Thanks for the tip - I'm on Windows 10 now and this is STILL driving me nuts. I'll give Iconoid a try; in addition to the external-monitor thing, Windows 10 occasionally likes to spontaneously re-arrange my icons after a reboot. (Well, ALL versions of Windows have done this once in a while, but 10 has been doing it a LOT - more than any version I've used since Me.) If Iconoid can stop this, it will be a lifesaver.
    – MT_Head
    Feb 17, 2016 at 20:10
  • Thought I'd come back and report: Iconoid has done the trick! I just need to remember to run it and do a backup on a semi-regular basis.
    – MT_Head
    Mar 22, 2018 at 2:12
3

With no second-monitor attached, open the charms bar and click Devices, then Second Screen, then Extend.

I've been having the same problem as you, and this seems to change the behavior for the next time you connect another monitor. I can't tell whether or not this changes the default behavior forever and for any non-specific second-monitor, but it seems to prevent the resolution on my laptop's screen from changing. I'd suggest routinely checking that before you attach any other monitor.

3
  • Hmmm... I'll try that. I'm in standalone mode at the moment, so we'll see. If it doesn't work, the agonized scream of "Saaaaaaaaaaaam!!!!" you hear will be me. ;)
    – MT_Head
    May 13, 2013 at 18:07
  • 1
    I still haven't had a chance to try it with a previously-unknown monitor, but I can tell you: I don't want to do this all the time. Windows pretended that I was still connected to the last monitor I'd been plugged in to - so my mouse kept drifting off the right side of the screen into emptiness. Drove me NUTS, so I turned it off again. The next time I'm just about to plug in an unknown monitor, I'll try turning it on again temporarily and see if it preserves my icon layout...
    – MT_Head
    May 15, 2013 at 21:06
  • Update: it didn't work. Saaaaaaaaaaaaam!!!
    – MT_Head
    Oct 7, 2013 at 23:30
1

Well, you can try this trick. Create a text file in notepad and name it, lets say "ExtendScreen.reg. Then open it in notepad and right the following:

Windows Registry Editor Version 5.00

[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Run]
"ExtendScreen"="\"C:\\Windows\\System32\\DisplaySwitch.exe\" /extend"

Then save it. Of course if windows is in other driver than C: then you have to change it. Or you can use the following value instead of the previous one:

Windows Registry Editor Version 5.00

[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Run]
"ExtendScreen"=hex(2):25,00,57,00,69,00,6e,00,44,00,69,00,72,00,25,00,5c,00,53,\
      00,79,00,73,00,74,00,65,00,6d,00,33,00,32,00,5c,00,44,00,69,00,73,00,70,00,\
      6c,00,61,00,79,00,53,00,77,00,69,00,74,00,63,00,68,00,2e,00,65,00,78,00,65,\
  00,20,00,2f,00,65,00,78,00,74,00,65,00,6e,00,64,00,00,00

This is basically the same value but it's using Expandable String value instead of String value. The value is:

%WinDir%\System32\DisplaySwitch.exe\ /extend

This will be resolved every time windows boots up. This should force Windows 7/8/8.1/10 to select always Extend Desktop. All you have to do after saving that text file is to double click on it, or select it then hit Enter key. Windows will ask your permission to merge it with Windows Registry, just click on "Yes" button, then click "Ok".

1
  • 1
    You are making it too complecated. It would be enough to run "C:\Windows\System32\DisplaySwitch.exe /extend" inside a batch file and put it into the startup folder Jan 31, 2020 at 5:52
1

To extend by default put this line a batch file inside Startup folder:

"C:\Windows\System32\DisplaySwitch.exe" /extend 

And to clone by default this:

"C:\Windows\System32\DisplaySwitch.exe" /clone
0

You need to configure the Hardware Profiles, see my link below to TechNet it’ll describe how to do it.

http://support.microsoft.com/kb/308577

By the way, the layout of the options may be different for NT 6.2...

5
  • That article is for XP; I don't find an equivalent for Windows 8 (or 7, for that matter). Is there an equivalent in newer versions? Searching TechNet doesn't give anything useful: search.microsoft.com/en-us/…
    – MT_Head
    Mar 18, 2013 at 21:00
  • Also, I'm not at all sure that Hardware Profiles would solve my problem anyway. I want to change Windows' default behavior before I plug another external monitor. Looking through that article, I don't see a way to do that even if Hardware Profiles exist in Windows 8.
    – MT_Head
    Mar 18, 2013 at 21:44
  • Yes I believe Hardware Profs are an NT5.1/2 thing :( Mar 18, 2013 at 22:35
  • This is a dead link! Jan 31, 2020 at 5:54
  • Rather that down vote ancient posts why don't you read up on things yourself instead? Obviously Microsoft have been removing old posts related to un-supported software i.e WinXP... Feb 9, 2020 at 15:39

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.