27

I'm not using XFCE as a desktop environment, but I am using XFCE's terminal. Currently, when I press F1, I get the help. I really don't need this, and it's really annoying when I accidentally press it when in VIM when trying to press escape.

I didn't see anywhere in Preferences to change/disable keyboard shortcuts. Is there some hidden way to disable these shortcuts?

If it matters, I'm running xmonad on Arch Linux.

4

This page recommends adding blank accellator shortcuts to ~/.config/Terminal/terminalrc'. I run XFCE 4.8 and could not find this file myself. However, in my terminal preferences (under Edit), there is a shortcut tab. Help = F1 is the last shortcut in the list. My terminal emulator version is 0.4.8. Hopefully one of these will be applicable to you.

  • 3
    Hmm, doesn't seem to work for me. I'm running xfce4-terminal 0.6.1 for Xfce 4.10. I don't seem to have a shortcut tab... weird... – beatgammit Mar 7 '13 at 5:13
  • 2
    If I read correctly, then apparently if you however the mouse over the menu option for help, and press a new key, it will rebind to that key instead and free up F1. link. Seems dubious but it is worth a try. – washbow Mar 7 '13 at 5:21
  • Post #5 here suggests editing ~/.config/xfce4/terminal/accels.scm – washbow Mar 7 '13 at 5:22
  • 2
    That dubious link seemed to work. I had to restart X, but I was able to delete the shortcut. Thanks! – beatgammit Mar 7 '13 at 5:31
  • 1
    Under ubunto 14.04 I found the config file under .config/xfce4/terminal – Edward Falk Jun 30 '15 at 18:49
30

Copied from Function Key Binding in XFCE and the FAQ:

  1. Run xfce4-appearance-settings.
  2. Click Settings tab.
  3. Check Enable editable accelerators.
  4. Click Close.
  5. Open an xfce terminal.
  6. Click the Help menu.
  7. Hover over Contents (do not click).
  8. Press the Del key to delete the accelerator.

F1 disappears from the menu item.

The fullscreen accelerator, F11, can be removed similarly:

  1. Click View
  2. Hover over Fullscreen.
  3. Press Del.

Pressing any other key than Del reassigns the accelerator key to the key that was pressed.

8

on xubuntu 12.04 with xfce4-terminal 0.6.1 (Xfce 4.10) I've resolved adding:

in ~/.config/xfce4/terminal/accels.scm

(gtk_accel_path "<Actions>/terminal-window/fullscreen" "")
(gtk_accel_path "<Actions>/terminal-window/contents" "")

and in ~/.config/xfce4/terminal/terminalrc

AccelFullscreen=
AccelContents=

so both F1 help/contens and F11 fullscreen are disabled

  • 4
    Editing accels.scm alone works for me (version 0.6.1 on Arch). – lilydjwg May 8 '13 at 5:13
  • On Xubuntu 13.10 using xfce4-terminal 0.6.2. I created accels.scm with content above, not changing terminalrc, then closed all opened terminal windows. Then launching a new terminal window had the expected behavior: now F1 is passed to applications (e.g. mc). – Stéphane Gourichon Jan 6 '14 at 10:00
5

At least for xfce-terminal of version 0.8.6 or higher there is an option within preferences, where this can be easily set.

Terminal Preferences with option to disable F1

Yeah, this may seem obvious. I posted this in order for people landing here from their favourite search engine to know there is much easier way to solve the problem now.

0

Creating an accels.scm file also worked (without changes to terminalrc) in Xubuntu 13.04. Not sure why!

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.