How do I get my Windows 8 Metro apps to load? The tiles update, but when I click on them, they spin around and show the solid splash screen, then disappear. Only the Store app opens. I've tried:

  1. Setting user access control to one notch below the top.
  2. "Refresh My PC" (Don't do this - waste of time. Deletes all your desktop apps too.)
  3. Turned off real time scan of my McAfee anti virus.
  4. Went into Store app and updated apps.
  5. Ran sfc /scannow
  6. Ran the App Troubleshooter.

This is a new computer. I've already ran Windows update. They worked the first few days.

Here is a list of some event log errors: http://pastie.org/6415709

  • which apps aren't working, as the windows store works it seems to be specific apps not all apps in general. – Al_ Mar 7 '13 at 10:33
  • All apps. News. Weather. Finance. People. Mails... etc. Kindle. Skype. – Chloe Mar 7 '13 at 10:58
  • It sounds like your logged into the default Administrator account built into Windows. – Ramhound Mar 7 '13 at 10:59
  • I'm logged in as 'Chloe'. I do have Administrator rights, and I seem to be the only account besides Guest, which is off. – Chloe Mar 7 '13 at 11:17
  • There was a similar question from somebody in the past with a problem like this, they had installed a Windows 8 printer application, and they discovered this program was the reason this behavior surfaced. Sadly the only solution that worked for them was to do a fresh installation of Windows 8. – Ramhound Mar 7 '13 at 11:20

Try to run the App Troubleshooter:


Also make sure that the registry/folder permissions are not changed:

Win8: App: Modern: Apps fail to start if default registry or file permissions modified https://support.microsoft.com/kb/2798317/en-us

| improve this answer | |
  • Ok I believe I ran that too, because when I tried it just now, it downloaded AppsDiagnostics(1).diagcab. Here is the log of what it did: pastie.org/6415092. Will report back after reboot. – Chloe Mar 7 '13 at 20:44
  • No that did not work... – Chloe Mar 7 '13 at 20:50
  • I looked at the KB article, but did not see that error. Instead, I saw this error: pastie.org/6415279 – Chloe Mar 7 '13 at 20:56
  • In the KB article, I checked permissions, and only this was missing, which I added "Users\<userName>\AppData\Local\Microsoft\Windows\WER - Special Permissions (List folder / read data, Create Folders /Append Data)". Also, there was no HKEY_LOCAL_MACHINE\DRIVERS. The apps still won't load. – Chloe Mar 7 '13 at 21:52
  • Run process Monitor while trying to start an app. Now look into the result column for errors. – magicandre1981 Mar 8 '13 at 5:07

I had the same problem, the apps opened for a moment then minimized and did not open.

I found that this command from MSDN Blogs, fixes the issue for each app. Just Change the name of the app you are trying to fix and done.

  1. Open a elevated Command Prompt.

  2. Execute the following command:

powershell -ExecutionPolicy Unrestricted Add-AppxPackage -DisableDevelopmentMode -Register $Env:SystemRoot******\AppxManifest.XML

Example: To solve problem with WinStore App:

powershell -ExecutionPolicy Unrestricted Add-AppxPackage -DisableDevelopmentMode -Register $Env:SystemRoot\WinStore\AppxManifest.XML

To solve problem with Camera App:

powershell -ExecutionPolicy Unrestricted Add-AppxPackage -DisableDevelopmentMode -Register $Env:SystemRoot\camera\AppxManifest.xml

To solve problem with FileManager App:

powershell -ExecutionPolicy Unrestricted Add-AppxPackage -DisableDevelopmentMode -Register $Env:SystemRoot\FileManager\AppxManifest.xml

To solve problem with ImmersiveControlPanel App:

powershell -ExecutionPolicy Unrestricted Add-AppxPackage -DisableDevelopmentMode -Register $Env:SystemRoot\ImmersiveControlPanel\AppxManifest.xml

Another fix is from Technet:

The following finally fixed all issues for me (Store and all apps broken):

A.) Fixing the app store: Run from admin command prompt:

Powershell -ExecutionPolicy Unrestricted Add-AppxPackage -DisableDevelopmentMode -Register $Env:SystemRoot\WinStore\AppxManifest.xml

B.) Fixing all modern apps: Run from admin PowerShell:

((Get-ChildItem "HKLM:SOFTWARE\Microsoft\Windows\CurrentVersion\Appx\AppxAllUserStore\InboxApplications") | Get-ItemProperty).Path | Add-AppxPackage -Register -DisableDevelopmentMode

C.) Fixing 3rd party apps:

Delete the regkey:


You can find your SID by going to an elevated command prompt and typing

wmic useraccount get name,sid

| improve this answer | |
  • This fixed my problems I was seeing on the Windows 10 Technical Preview. Thanks a ton! – Codecat Nov 21 '14 at 19:28

I found a similar issue after a Steam game installed .Net Framework. My only solution was to do the factory reset in Windows 8 -> Charm bar -> Settings - Change PC Settings -> General it's the option up from the last saying "Remove everything and re-install Windows"

Unfortunately I never found out which .Net update messed it up.

| improve this answer | |

I just had this problem and found that uninstalling and reinstalling the apps fixed it - except for a couple of apps that I didn't use much. You can delete all the apps that aren't working properly, then go into the Store and select the 'Your Apps' option. It will list all the apps you had installed, so you can select them all and reinstall them all with one click.

It's worth trying this before resetting or reinstalling Windows.

| improve this answer | |

I tried everything posted to fix this problem The last thing I did was try: ALL APPLICATION PACKAGES need the following permissions to execute properly:

Read & execute, List folder contents and Read in the following locations
C:\Program Files (x86)
C:\Program Files
List folder and read data, Create Folders and Append Data

My HKEY_CLASSES_ROOT was wrong Fixed it and Modern Apps run OK

| improve this answer | |

I had the same problem after I decided to move my users and appdata folders to my d: drive.

Apparently "modern ui" (aka Metro) simply won't work if you do this:


| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.