Win7 64bits up-to-date (March 7th 2013)
I get apache 2.2 installed and it worked fine in the past (weeks/month/years ago), with php5.
To day I needed apache for some tests so I run it (apache monitor). However I got an error (surprise, wasn't it OK before ?).

edited March 23rd : Windows AUC was set to level 2 and that caused the described issues.
(same issues with level 1)
When I reset AUC to lowest level, things went back to normal.
So I changed the Title.

So I started investigating apache config files (from experience issues are often there...) and ended up totally puzzled.

  1. I restarted from the conf/orig/httpd.conf (the saved original apache config file) and copied it back to apache/conf folder.
  2. Apache starts fine.
    However, I can't update it (why ?)
  3. So i create another http.conf.my in same folder to edit and play upon.
  4. I remove conf.httpd
  5. I rename httpd.conf.my into httpd.conf
  6. Looks like apache works fine.
    However :
  7. I copy httpd.conf into httpd - copie.conf
    And then (I am not mad as I could reproduce this several times just to beleive it) :
  8. PSPAD/diffText shows:
  9. httpd - copie.conf is exactly the same as **conf/orig/***httpd.conf* (all my modifs are lost)
  10. I double check httpd.conf and I can see my modifs there.
  11. So what the hell happened when I copied httpd.conf into httpd - copie.conf ?

I just have no idea what could go wrong.
I checked the C: drive with windows drive check tool (requires reboot) which found no issue.
It looks like there are two httpd.conf :
- One (the apache original one which I copied from apache/conf/orig) which does not show any more in apache/conf and is the apache original one.
- One (the one with my edits) which fools me

It looks like when I copy httpd.conf, win7 takes the hidden one.
I beleive apache too takes the hidden one.

I noted too :

  1. I edit httpd.conf with notepad++ : I can see my edits (yes it is the content of httpd.conf.my. I close
  2. I remove httpd.conf
  3. I refresh the folder and indeed httpd.conf is not there
  4. Under notepad++ file menu (file history), I can reopen httpd.conf
  5. It shows with my edits. I edit and save
  6. the file httpd.conf does not show in the folder I tried to reproduce this with another file on my desktop.
    At step 4 Notepad ++ warns that the deleted file does not exist and propose to create ...

My questions are :
Can anybody understand what happens ?
What can I do so solve the issue ? (= be able to edit and save my edit trustfully).

  • This I did already (needs reboot as drive is C: ). However, I guess what I need is ways to investigate at low level the file system and the content of this conf folder. I don't know enough of power shell. Can someone help ? – gerard Mar 8 '13 at 7:21
  • Issues come with using windows AUC. I set AUC to lowest level and then I could properly set apache config and run Apache. Still the behaviour was extremely strange and reproducible. – gerard Mar 23 '13 at 8:15

Your Answer

By clicking "Post Your Answer", you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.