65

Chrome's autocomplete for searches is often very annoying and intrusive because it is opt-out. It autocompletes by default and you have to press Backspace to dismiss it. Google search suggestions are welcome but sometimes I just want to type what I want.

There's an option for "Use a prediction service to help complete searches and URLs typed in the address bar" but this disables suggestions also. Is there any way to disable autocomplete without losing suggestions?

9
  • 2
    I'm presuming the question is that in the title, it is unclear from reading your question. You seem to be saying, "I want to eliminate suggestions, but at the same time I don't."
    – Dan
    Mar 7 '13 at 20:58
  • I edited it to hopefully be more clear. Mar 7 '13 at 21:12
  • 1
    I don't think Google differentiates between autocomplete and suggestions with search - it's all or nothing. Are you possibly referring to autofill (completing forms)?
    – Dan
    Mar 7 '13 at 21:18
  • 1
    I even checked about:flags and there was nothing that lets you control one without affecting enabling/disabling the other
    – Dan
    Mar 7 '13 at 21:36
  • 10
    Major bummer.... Suggestions are extremely useful but autocomplete is extremely annoying.
    – jahroy
    Jul 5 '13 at 18:41
50

It can never be fully disabled, unfortunately. You can clear your browser history (including all new history being cleared on session exit every time) and follow the below steps to get close to the desired results.

In current versions:

  1. From the Privacy and security section, click Sync and Google services
  2. Disable Autocomplete searches and URLs

In older versions of Chrome:

  1. Go to the Chrome menu on the browser toolbar looks like this
  2. Click Settings
  3. Click Show advanced settings (on the bottom)
  4. In the Privacy section, deselect the "Use a prediction service to help complete searches and URLs typed in the address bar" checkbox

Keep in mind that the address bar shows matches from your browsing history, in addition to predictions. If you don't want to see matches from your browsing history, you must clear that as well.

Beyond that there is nothing more you can do. It is either all or nothing. You cannot modify the behavior of how you dismiss suggestions. Suggestions and autocomplete are the same service.

11
  • 2
    See support.google.com/chrome/answer/95656. I was interested in removing matches from my browsing history as well. To do that, you need to clear your browsing history. I'm also interested in preventing browsing history from being kept so that I don't have to keep doing this. It seems the only way to do that is to use Incognito ("If you don’t want Chrome to save your browsing history at all, you can switch to Incognito mode." - support.google.com/chrome/answer/95589) Mar 1 '17 at 7:02
  • 1
    From the original post, he wanted to keep suggestions, but remove the auto-added highlighted part.
    – NessDan
    Oct 19 '17 at 15:43
  • 1
    this answer is wrong superuser.com/a/543412 Dec 16 '17 at 19:50
  • 2
    Wrong: this disables google's autocompletion based on other user's searches, but keeps showing my own searches in autocompletion. I want precisely the opposite: I don't want it to keep track of my search queries (which is intrusive in my opinion, I'm not searching for porn or anything in public mode, but I still don't want my colleagues to see the history of my search queries and topics that interest me), but want to keep autocompletion based on popular queries. Jan 30 '19 at 11:52
  • 1
    @Dan Thanks for this suggesting, it is a useful option, but I don't want to lose my browser history as I often look something up in it. I just don't want the browser to display my previous queries while doing the auotcompletion. Jan 30 '19 at 14:06
4

For me there are two different things to do. The first one has been already marked as the correct answer. In brief:

  • Go to Chrome preferences - Advanced options - Disable: Use a prediction service to help complete searches and URLs typed in the address bar

However I still see, in addition to sites saved as bookmarks, URLs that I frequently visit. So the second thing to do to remove those entries is to:

  • When the unwanted URL appear, type Shift+Del (Windows) or Shift+Function+Delete (Mac) (Full answer here). I guess you can also clear all history cache, if you prefer!
1
  • If you have a recent Chrome version - Version 90+ - use this answered here on this site.
    – Timo
    Aug 17 at 14:53
3

My biggest complaint is that I type a hostname into the address bar (just a host name, not and FQDN) and Google Chrome goes off and searches for the hostname instead of going to it. And now it is surrounded by a bunch of URL so I hate to type it again!! Grrr!!!!

I found something that seems to completely disable searches in the address bar in Google Chrome.

Settings

  • Search engine
    • Manage search engines
      • Other search engines
        • Click Add
          • Search Engine - NONE
          • Keyword
            • anything you won't accidentally type in the address bar
            • P1Sn1Q4XhBViV2QoEQaggtcGxUZ3EYvg
          • URL with %s in place of query
            • Just %s, nothing else
            • %s
          • Click Add
      • Other search engines
        • NONE
          • Click the vertical ellipsis ⋮
            • Select - Make default

Now, when you want to search in the address bar, you can, by typing the "Keyword" for the search you want and then your search terms.

BUT :-) just typing into the google.com web page search will Not take you to the address bar!

1
  • This did not work for me. Just %s alone is changed by Chrome into "http://%s" which is not a valid url most of the time. Instead I used "google.com/search?q=%s" and that works. May 22 at 14:13
3

I'd just wanted to indicate that I did a bit of trial and test and I found one option that works well for just typing things in the address bar, and not going to the first search result.

It's pretty simple: control-enter instead of just enter will input just the typed text instead of the first suggestion. Note that if the server name is not complete it will try to e.g. add .com to it so it is not perfect. But for going to local addresses it will suffice (instead of going to the suggested 192.168.I78.X - note the I instead of the 1 - which I probably searched for by mistyping or something similar).

Tested on Chrome version 90.0.4430.212 (64 bit Windows).

Not the answer you're looking for? Browse other questions tagged or ask your own question.