45

How can I stop the Research Pane from appearing in Microsoft Office, for example when I am holding Alt and click somewhere in an email in Outlook?

This is unintentional and typically happens when I am Alt-Tabbing between windows and causes a painful delay. Can this be switched off?

enter image description here
click to enlarge

2
  • Which Microsoft Office do you use? 2007 or 2010 (or something else)?
    – Rolnik
    Mar 30, 2011 at 21:27
  • 2
    For those interested in the bounty, I'm referring specifically to 2007 if it makes a difference but I suspect it doesn't. Apr 4, 2011 at 20:33

8 Answers 8

42

After fighting with this myself for years, I found out the answer.

From Word, press Alt-F11 to open the VB Editor.

Press Ctrl-G to open the Immediate Window.

Type this line and press Enter:

Application.CommandBars("Research").Enabled = False

Note that nothing will seem to happen, but you can go ahead and close the VB Editor and Word. The next time you open Outlook, the feature should be disabled.

8
  • 2
    The original question mentioned Outlook, not Word. When I try this with standalone Outlook I get "Object does not support this method or property".
    – Burhan Ali
    Oct 17, 2012 at 15:50
  • 6
    In Outlook I appear to have got it working with Application.Explorers(1).CommandBars("Research").Enabled = false Sep 26, 2013 at 9:09
  • 6
    Using Microsoft Word 2010, this appears to work: Application.ActiveWindow.CommandBars("Research").Enabled = False Dec 4, 2013 at 15:35
  • 1
    This works perfectly fine, thanks for the solution! (Tested on MS Word 2013) Jan 22, 2014 at 10:50
  • 4
    David Cornish's solution worked for me: Application.Explorers(1).CommandBars("Research").Enabled = false
    – ScrappyDev
    Sep 25, 2015 at 17:44
10
+25

Unfortunately, the answer is "No, this can't be switched off".

People have been wondering this for quite a while now (here's some examples dating back to like 2007):

You'll probably have to rig up something kludgy to trap the keys using AutoHotkey or AutoIt or alike.

Couple things you can try to live with it:

  • Remove all entries from the Research Options and ensure it's not trying to access network-based research services (so at least it will open quickly).
  • Leave the pane open all the time (just shrink it down a bit, or undock it and hide it someplace out of the way).

Not the answer you want I'm sure, but it's the answer as far as I can find.

4
  • +1 for the research revealing shared misery at least, and also for the other good suggestions for reducing the headache Apr 4, 2011 at 20:36
  • Thanks, glad to know it's not just me. Appreciate your time in investigating this. Apr 5, 2011 at 13:41
  • Daniel, @rzlines Oct '09 response was correct and works well when add/remove is run as Administrator. Some registry edits to complete the cleanup. Apr 6, 2011 at 2:46
  • Validated answer from Jon worked in Office 2016, see my comment in his answer
    – Mat M
    Oct 23, 2020 at 12:56
4

I was able to turn mine off by opening the Outlook options menu (File > Options). Then go down to the Add-Ins sub-tab.

Once in the Add-Ins menu, go to the bottom where it says, "Manage [COM Add-Ins]" and click on the Go button. Uncheck the box next to "Business Connectivity Services Add-In", then click OK.

This should keep the research pane from opening.

2
  • I don't see 'File > Options' in Outlook? Jul 24, 2013 at 15:43
  • Are you sure that add-in is related to the Research Pane? I get the pane but there is no "Business Connectivity Services Add-In"
    – golimar
    Nov 27, 2019 at 14:31
3

You can also do this in Outlook via VBA. Office 2010 no longer lets you remove via most of these solutions.

Word, PowerPoint, and Excel allow you to use this easy solution.

Outlook requires more hassle as it uses both Explorers and Inspectors, which in different contexts both have this commandbar enabled. The solution is therefore two part.

Part one is setting up WithEvents to handle creation of each new Inspector. Generally these are whenever you OPEN a message/event/etc, and they are created/destroyed each time. So even if you hit every current Inspector, your new ones will not have the commandbar disabled.

Put the following into ThisOutlookSession in your VBA editor (Alt+F11). Each new inspector (and explorer, too, though I've yet to have an explorer created) will have its command bar disabled.


Public WithEvents colInspectors As Outlook.Inspectors
Public WithEvents objInspector As Outlook.Inspector
Public WithEvents colExplorers As Outlook.Explorers
Public WithEvents objExplorer As Outlook.Explorer

Public Sub Application_Startup()
    Init_colExplorersEvent
    Init_colInspectorsEvent
End Sub
Private Sub Init_colExplorersEvent()
    Set colExplorers = Outlook.Explorers
End Sub

Private Sub Init_colInspectorsEvent()
    'Initialize the inspectors events handler
    Set colInspectors = Outlook.Inspectors

End Sub

Private Sub colInspectors_NewInspector(ByVal NewInspector As Inspector)
    Debug.Print "new inspector"
    NewInspector.commandbars("Research").Enabled = False
    'This is the code that creates a new inspector with events activated
    Set objInspector = NewInspector
End Sub
Private Sub colExplorers_NewExplorer(ByVal NewExplorer As Explorer)
    'I don't believe this is required for explorers as I do not think Outlook
    'ever creates additional explorers... but who knows
    Debug.Print "new explorer"
    NewExplorer.commandbars("Research").Enabled = False
    'This is the code that creates a new inspector with events activated
    Set objExplorer = NewExplorer
End Sub

However this only will get the menu gone from some of the views in Outlook. You will still need to run the following macro to remove it from all explorers. As best I can tell this is persistent when you close/reopen Outlook:

Private Sub removeOutlookResearchBar()

    'remove from main Outlook explorer
    Dim mExp As Explorer
    For Each mExp In Outlook.Explorers
        mExp.commandbars("Research").Enabled = False
    Next mExp

End Sub
2

Try this:

Add/Remove Programs ---> Microsoft Office ---> Add or Remove Features ---> expand Office Tools ---> disable Research Explorer Bar

source

2
  • 1
    I tried that and unfortunately it hasn't worked - I still see the research pane appearing when I hold down Alt. Mar 9, 2010 at 15:22
  • Andrew, you may want to check on that. It has to be for all Office 2007 users on the PC, but when run as Administrator the Add/Remove Programs --> Microsoft Office --> Add or Remove Features Installation Options --> Office Tools --> Research Explorer Bar set to "Not Available" and Continue. Followed by reboot is honored. Research bar is disabled. The per user HKEY_CURRENT_USER\Software\Microsoft\Office\12.0\Common\Research Key can be cleared. Highlight <alt> should no longer result in Research bar launch. Apr 6, 2011 at 2:36
1

In Outlook try this; it won't disable but will prevent freezing.

  1. Hold Alt & Left Mouse Click on a word to open the Research pane
  2. On the bottom of the Research pane click "Research Option"
  3. Under "Services" uncheck everything
  4. Click "Ok" to save the changes
1
  • This still causes the Research pane to open it just stops it displaying any results.
    – ChrisB
    Jun 28, 2019 at 9:31
0

If you don't want to disable the Research alt-click, but want to avoid it happening while you're alt-tabbing between windows, just avoid clicking within the content area in the Office app (i.e., click on the title bar or scrollbar etc). This avoids triggering Research.

0

Put a toggle button on your QAT. So you can turn it on when you want it!

In word I put this in Normal.dotm VBE:

    Sub Y___ResearchPane_ToggleDisableEnable_QATButton()
    If Application.CommandBars("Research").Enabled = False Then
         Application.CommandBars("Research").Enabled = True
         MsgBox "Research Pane enabled, click again to disable"
    Else: Application.CommandBars("Research").Enabled = False
         MsgBox "Research Pane disabled, click again to enable"
    End If
    End Sub

Then rightclick QAT, customise, type M in the choose commands box, enter, tab, select the macro. In the QAT box click the line you want your macro below. Click add, modify the name as required, and assign a button - done!

Not the answer you're looking for? Browse other questions tagged or ask your own question.