2

I'm starting to see a very interesting issue. Some icons are being shown as 'default' icons despite the fact that they launch fine with their proper associated programs. This is in the traditional desktop mode, not the Metro mode. I've attached a screenshot, one showing the Outlook 2013 icon in the taskbar and the other showing a PDF icon in Windows Explorer.

enter image description here

How do I fix this to get the proper icons displayed? Again, the application launches just fine.

Update

Rebuilding the icon cache doesn't seem to help on Windows 8. i.e.

  • delete c:\users\<username>\AppData\Local\IconCache.db
  • reboot
  • same problem as before.

The icon cache rebuilder tool doesn't seem to allow me to rebuild the cache either: enter image description here

1

Unfortunately, none of the responses helped. The issue was corruption within the C:\Windows\Installer folder (folder empty). For some reason all shortcuts were using icons that lived inside the installers there instead of the actual programs themselves. I guess this is a weird Windows 8 issue. I had to reinstall the programs to get the installer folder populated and then the path to icon files worked and the icons came back. It's pretty hard to have all the installers also live on your hard drive when you have an SSD (they aren't that big). Painful.

  • 1
    The missing files were probably erased by a disk "cleaner". Avoid such programs, and certainly not in C:\Windows except for C:\Windows\Temp. – harrymc Mar 20 '13 at 8:45
1

This worked for me:

Right click on one file in File Explorer -> Properties -> Change Icon

My Excel icons had somehow got changed to Adobe Acrobat icons; I uninstalled Acrobat and then they changed to Windows Explorer icons!

I changed the icon on one file as above, back to Excel, and it changed all the other similar file icons at the same time

1

After having this problem myself for weeks, I finally figured out the way fix it.

  1. Delete the value in Default in your registry for: HKEY_CLASSES_ROOT\exefile\shellex\IconHandler\
  2. Delete your c:\users\<username>\AppData\Local\IconCache.db as others have posted before.
  3. Kill explorer.exe and run a new instance of explorer.exeto refresh it.

And that should fix your problem, or at least it did for me while everyone else's answers failed.

  • This one worked. I've tried EVERYTHING I could find for many hours and this one is the one that did it. – Commander Aug 7 '15 at 19:11
0

You might try the free Icon Cache Rebuilder.

Although conceived for Windows 7, it might still work for 8.

0

Open regedit.exe and check HKEY_CLASSES_ROOT.ico

You will probably find its default in the right pane is set to icofile (if it isn't, change it to that) then go to HKEY_CLASSES_ROOT\icofile\DefaultIcon Highlight it and in the right pane double click on Default and set to %1 and reboot if necessary

If that doesn't work, try %1 with quotes instead (so "%1")

Hope it works!

0

I was having this issue with a program I was developing.

It seems that in Windows 7/8 the Taskbar and Program Files shortcuts icons are not taken from the .exe files icon as they used to be. Instead you have to assign an Icon to the actual shortcut itself.

I don't know why these shortcuts are not being set correctly, this should be taken care of by the installer, however you can fix them by manually setting an icon to the shortcut.

I suggest creating a shortcut on the desktop, setting the icon files and then pinning that shortcut to the Taskbar and Program Files, as you can't right click and view properties of pinned shortcuts.

Right click shortcut -> Properties -> Change Icon

If you need to create an .ico file to use as an icon. I like to use this website to convert JPGs, as it's quick and easy, although GIMP can also create them.

  • I can't assign icons, see superuser.com/questions/566575/… – DeepSpace101 Mar 15 '13 at 16:49
  • @sid That's a .docx file. I was describing doing it to a shortcut which has a different Properties menu, so instead try modifying the Program Menu shortcut to Microsoft Word (assuming that what you are using to read .docx files) – Amicable Mar 15 '13 at 16:54
  • @sid This is where it should be located C:\ProgramData\Microsoft\Windows\Start Menu\Programs, it might be slightly different on Win8. I don't have access to a win8 machine right now to check. – Amicable Mar 15 '13 at 16:56
  • Similar issue. I've updated that question too – DeepSpace101 Mar 15 '13 at 17:20
0

I would suggest reinstalling Adobe Reader and Office 2013.

0
  1. backup your registry, just in case (I recommend also to create a restore point)
  2. start regedit
  3. navigate to HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Explorer and expand it
  4. find "Shell Icons" key (note: this key does not normally exist in fresh Windows 8 installation, I guess IconPackager adds it)
  5. delete it (or rename it if you are not sure)
  6. restart your computer

For more information visit this forum site : http://forums.wincustomize.com/436401

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.