I can not explain what has happened, just suddenly I lost my internet connection. On local area connection properties IPv4 is not installed, my ISP says that they only support IPv4. Then I must had it because I had connection before. What could happen to lose IPv4? And how to install it back?

Thank you.

  • Have you tried to remove the network connection?
    – Ramhound
    Mar 8, 2013 at 21:37
  • @Ramhound Local area connection has disabled delete option in context menu. Do you mean that? I did create another wireless connection via wireless usb adapter, and it also is missing IPv4. Thanks.
    – eomeroff
    Mar 8, 2013 at 21:43
  • Well its not possible to disable the IPV4 Adapter. Specific information about the hardware in question would be helpful. Have you tried a non-wireless connection?
    – Ramhound
    Mar 8, 2013 at 21:51
  • Realtek PCIe GBE Family Controller is network card.
    – eomeroff
    Mar 8, 2013 at 22:13
  • Have you tried a System Restore back to before it broke? Mar 9, 2013 at 19:11

3 Answers 3


way 1:

Run cmd as Administrator. Run command:

netsh interface IPV4 uninstall 

Wait 2-3 minutes, run:

netsh interface IPV4 install

way 2:

Run cmd as Administrator. Run command:

resets WINSOCK entries to installation defaults

netsh winsock reset catalog

resets IPv4 TCP/IP stack to installation defaults:

netsh int ipv4 reset reset.log


netsh int ip reset reset.log

need reboot

way 3:

Run ncpa.cpl as Administrator.

Right-click the network connection which you are using, and then click Properties.

Click on Internet Protocol TCP/IPv4.

Click Install then.

Click Protocol, and then click Add.

Click Have Disk.

Type the location as %windir\inf%, example: C:\windows\inf and then click OK.

On the list of available protocols, click Internet Protocol (TCP/IPv4), and then click OK.

way 4:

wmic nicconfig get MACAddress, IPAddress, ServiceName, Caption, IPEnabled, SettingID | find /I "Realtek"

Get NIC GUID and del HKEY_LOCAL_MACHINE\SYSTEM\ControlSet00x\Services\{GUID} in registry.

wmic nic get Caption, PNPDeviceID, ServiceName, NetConnectionStatus | find /I "Realtek"


If it is difficult steps to improve law, registry entries, and then override the owner can use the Windows Driver Kit (WDK) 7.1.0.

Run regedit with SYSTEM rights.Need Windows Driver Kit (WDK) 7.1.0:

ntsd -c qd regedit

Scott Chamberlain (c), good comment!:

You can run regedit with SYSTEM rights by using PSExec too, much smaller download. One of the examples they post is running regedit as SYSTEM.

psexec -i -d -s c:\windows\regedit.exe


way 5 (apply if in a pinch, if the previous methods did not help):

/1. Back up Registry /2. Edit file %windir%\inf\Nettcpip.inf in [MS_TCPIP.PrimaryInstall]

comment string ;:

;    Characteristics = 0xA0 ; NCF_HAS_UI | NCF_NOT_USER_REMOVABLE

and add

Characteristics = 0x80

Nettcpip.inf ipv4 enable Uninstall

/3. Control Panel->Network Connections->Local Area Connection->Properties

enter image description here

Install protocol. Press Install button, select protocol, type Windows Inf path.

enter image description here

Select IPv4 protocol. (Unblock IPv4 uninstall button.)

enter image description here

Uninstall IPv4.

enter image description here

/4. delete registry key:


if need, delete registry key:


enter image description here


enter image description here

/6. Install IPv4

enter image description here

/7. Reboot!

enter image description here

/8. Restore %windir%\inf\Nettcpip.inf

/*. See too Re-installing WAN miniport devices

  • 1
    I have tried, it did not help. Thank you.
    – eomeroff
    Mar 8, 2013 at 22:11
  • 1
    I tried way 2 ant it also did not help. I can not find reset.log file :(
    – eomeroff
    Mar 8, 2013 at 22:36
  • @SonOfOmer netsh int ipv4 reset C:\resetlog.txt or netsh int ip reset C:\resetlog.txt ?
    – STTR
    Mar 8, 2013 at 22:48
  • 1
    I tried way 4. I could not delete registry entry in second action. Neither I could set full permissions over registry.
    – eomeroff
    Mar 9, 2013 at 18:03
  • 2
    You can run regedit with SYSTEM rights by using PSExec too, much smaller download. One of the examples they post is running regedit as SYSTEM. psexec -i -d -s c:\windows\regedit.exe Mar 9, 2013 at 19:00

From the Device Manager, navigate to Network Adapters and expand the tree. Right click and uninstall the ethernet card and reboot. Windows should autodetect the card and reinstall the appopriate drives. This should re-enable IPv4.

  • This fixed the problem for me. Apr 15, 2014 at 12:41

Got to Networking and sharing then Click on change adapter. Then right click on local area connection.

Double-click on Internet Protocol version 4 (TCP/IP4) and change as follows:

enter image description here


  • This duplicates another answer and adds no new content. Please don't post an answer unless you actually have something new to contribute.
    – DavidPostill
    Oct 14, 2016 at 8:35

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge that you have read and understand our privacy policy and code of conduct.

Not the answer you're looking for? Browse other questions tagged or ask your own question.