3

My Asus G51Vx originally had one hard drive, a 320 GB drive. The laptop came with Windows Vista and I replaced it with Windows 7.

Later I opened it up, voided the warranty, and installed a second 500 GB hard drive, and I left Windows 7 installed on the 320 GB drive. After a while the 320 GB drive proved to be too small, so I did a backup of both drives with Acronis True Image 2013 to an external hard drive. I got a new 1 TB drive for the laptop and restored the image of the 320 GB drive to the newer 500 GB drive, and restored the original contents of the 500 GB drive to the 1 TB drive.

The files all came back intact, but I'm now having some strange issues with my hardware. Several devices in the device manager are showing up with little yellow road signs by them, and are reporting the following error:

A driver (service) for this device has been disabled. An alternate driver may be providing this functionality. (Code 32)

These include the following devices:

  • High Definition Audio Controller
  • Intel(R) Core(TM)2 Duo CPU P7350 @ 2.00 GHz (twice for both cores)
  • Base System Device
  • Microsoft Virtual WiFi Miniport Adapter

I read in step 2 here that this issue is sometimes caused by swapping out hardware, but "Undo the change if you can" isn't really what I want to do, I don't want to put the old hard drive back in. So how can I get my laptop working again without putting the old hard drive back in? (Or is that not what they mean here?)

4

Fastforward 5 years, two OS versions up (8.1), and the latest version of Acronis True Image, and I had this same thing happen. So from what I can tell, when you do this, for whatever reason, the HD audio bus driver service gets disabled in the registry, which nukes your sound.

The solution for me was to edit the following registry key:

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\HDAudBus\Start - set it to 1 if it's set to 4.

After doing this and rebooting, audio was still disabled, but then as if by magic, after a few minutes, audio started working again. I'm going to reboot one more time before I say my hallelujah amens, but after spending 4 hours of conducting windows repairs, bashing my head against the wall and nearly resigning myself to a wipe, being able to hear sounds coming out of my PC is beautiful.

| improve this answer | |
  • Thank you for sharing! This has fixed my HD Audio Controller Code32 after cloning Lenovo W530 SSD and inserting into similar W530. Everything was fine except the audio. 2 High Definition Audio Controllers were listed in the Device Manager and both with warning triangle. Installing/Updating drivers to native RealTek from Lenovo web site didn't help. Setting HDAudBus start to 1 has enabled the audio with the next reboot. – andrews Aug 14 '18 at 12:43
  • +++++ Thanks for this. I ran into this after cloning my Windows install to a new SSD and we on the verge of reinstalling when I found your answer and it worked! Thanks so much for sharing! – rcbevans Jan 15 '19 at 8:42
  • This was it. Colleague had booted a Acronis True Image and without doing anything - because it was too old and didn't recognize the harddisk - started Windows again and sound wouldn't work. Uninstalled drivers, updated drivers, nothing worked. This did. – Wiste Apr 23 '19 at 8:52
1

Try reinstalling the drivers if you can get your hand on the set-up files. They could exist in a folder called SWsetup in the root of your local disk (C:).

If you don't have this folder, you could get it from a friend who owns the same (or a very similar) model of your laptop, especially if it came with a preinstalled version of Windows 8. Or you could download the drivers individually from the hardware manufacturers. Point remains, you'll need to reinstall the drivers that are missing...

Here's another option. I'm not sure it will work, but try it. Right click on your computer icon and select "Manage". Switch to the "Device Manager" tab, and search for the malfunctioning hardware, right-click and select update drivers. Select the option that searches for drivers online and wait for the PC to do its thing.

This is pretty unprofessional advice, but I think it should work.

| improve this answer | |
  • 1
    Yeah I ended up just uninstalling the devices and restarting my system. All but one of them installed correctly. "Base System Device" I believe it was called. Sounds like Windows doesn't know what it is...but it's probably the driver for the IR port, that thing never worked right. – leeand00 Mar 9 '13 at 16:45
0

Uninstalling and then reinstalling the drivers for the device is a likely solution to a Code 32 error. This procedure should correctly reset the start type in the registry. If a USB device is generating the Code 32 error, uninstall every device under the Universal Serial Bus controllers hardware category in Device Manager as part of the driver reinstall, including any USB Mass Storage Device, USB Host Controller, and USB Root Hub devices. Correctly reinstalling a driver, as in the instructions linked above, is not the same as simply updating a driver. A full driver reinstall involves completely removing the currently installed driver and then letting Windows install it over again from scratch.

| improve this answer | |

Not the answer you're looking for? Browse other questions tagged or ask your own question.