1

Tearing my hair out - hoping someone can spot my (probably obvious) mistake:

I'm setting up a home LAN running Windows 2008 R2 with Windows 7 Ultimate clients. I'm trying to redirect the various libraries to locations on a separate NAS box.

I've set up a DFS for the NAS under server.private\LAN folders

Documents - basic, mapped to create a folder for each user under:

\\server.private\LAN folders\ServerUsers

Music - advanced, for all users in the "Music" group, I'm redirecting to a central share:

\\server.private\LAN folders\Central Music

Pictures - advanced, for all users in the "Pictures" group, I'm redirecting to a central share:

\\server.private\LAN folders\Central Pictures

I've created a user who is a member of both the "Music" and "Pictures" groups. The documents and music folders map perfectly, but pictures is just on the local machine.

I can't find anything different between my music and pictures settings, and the share permissions for the folders are identical (I've even tried changing the policy entry so that the pictures library points to the music folder and works for members of the "Music" group - that doesn't work either).

I've also tried redirecting the "Movies" library in the same way - again this is unsuccessful.

Is there something different in how the "Music" library is managed in Windows compared to the others?

Am clearly doing something stupid - any suggestions on where to look very gratefully received!

5
  • The event log should contain error entries for when a folder redirection can not be set up. Are there any errors in yours? Mar 9, 2013 at 23:16
  • @DavidFulton Is this a domain environment? Mar 10, 2013 at 0:34
  • This is a domain environment, yes. Mar 10, 2013 at 11:32
  • Have trawled the server logs - the only entries I can see of any significance are the odd line that states "Folder redirection policy application has been delayed until the next logon because the group policy logon optimisation is in effect". Mar 10, 2013 at 11:35
  • I think part of the problem may be propagation of the policy. The central pictures one is now working as it should (several reboots / logons after it was set up), as is the "videos" one I set up to test the theory. However - I've since changed the destination of the "videos" one and it still hasn't taken effect 12 hours and a reboot later. I've tried gpupdate /force on the client without success. Is there something else obvious I'm missing? Mar 10, 2013 at 11:38

1 Answer 1

1

Finally cracked this - it wasn't an issue with configuration but with propagating the revised Group Policy settings to the client machine. The entries that weren't working were ones I'd changed after I'd first logged in to the client account and I think my roaming profiles were sometimes caching out of date policies.

While I've found countless references to the gpupdate /force command, this never appeared to have any effect for me. The final solution that worked was to delete the profile data on the client. As soon as I did this, my new policy settings were applied.

I should also share the technique for deleting profile data, as this caught me out. I (wrongly) assumed I could simply delete the user folder on the client hard drive, but this resulted in all sorts of strange connection errors and temporary profile issues on subsequent log-ins. The correct way to remove a user in Windows 7 is detailed in the Microsoft Knowledge Base article here. Note that most times, I only needed to do the first part of the process. I think you only need to do the second step (manual registry editing) if you've already made a bit of a hash of your local profiles!

There's probably a slicker way of solving this problem - but if group policy doesn't update right on a client machine, this technique seems to work.

Have updated title of original post to better align question to ultimate solution.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.