6

I ran into some trouble while trying to install .net framework. My laptop (sony vaio vgn cr41z if it matters) running on windows 7 x64, just shuts down during the installation process. No blue screen, no error message, no logout screen, no nothing. No errors even when I reboot. I had a look into this error log:

enter image description here

I searched stackoverflow for similar problems, but all I found was applications developed under various versions of .net crashing with the same error code (80131506). I tried to install .net 3.5, 4.0 and 4.5. Standalone installer, web installer, even via Windows Update. The same problem...

LE: I think this is a hardware or driver issue. I even changed the OS (Windows 8 Pro x64) and the problem wouldn't go. Good thing I have my desktop near. :)

migrated from stackoverflow.com Mar 10 '13 at 3:11

This question came from our site for professional and enthusiast programmers.

  • Do you have anti-virus? It can be really picky about what access it gives to the .NET folder. – skub Mar 10 '13 at 3:26
3

The problem was that my computer was shutting down due to abnormal processor temperature. That's why I couldn't install .NET framework and some other programs. I solved this by going to Control Panel -> Hardware and Sound -> Power Options -> Change plan settings (on the active power plan) -> Change advanced power settings, and setting the Maximum processor state from 100% to 75% like this:

solution print screen

This worked for me.

  • ok, nice find. You should try to use Speedfan and increase the speed of our CPU fan. – magicandre1981 Mar 12 '13 at 19:14
1

You get an internal error:

C:\Users\Andre>err 0x80131506
# for hex 0x80131506 / decimal -2146233082
  COR_E_EXECUTIONENGINE                                          corerror.h
# An internal error happened in the Common Language Runtime's
# Execution Engine
  COR_E_EXECUTIONENGINE                                          corerror.h
# 2 matches found for "0x80131506"

use the .Net Clean Up tool to kill every old .net entries. Now reboot and try to install .net 4.5 again (3.5 is part of Windows 7 and 4.0 is replaced by 4.5).

0

Try installing .NET 1.1 and .NET 1.1 SP1 before trying to install. This is a relatively documented but the symptoms are very slightly different.

It's an older hack sir, but it checks out.

  • As you might already know, windows 7 comes with .net 3.5.1 already installed. Should I uninstall that one too ? – Octavian Mărculescu Mar 9 '13 at 23:55
  • Personally I would get rid of every trace before moving forward and since you already tried something in between 3.5.1 and 4.x I would say at least try the service pack but you'll probably need to scrape it all out. – tmwoods Mar 9 '13 at 23:56
  • I tried that, but no luck... I managed to see for almost 1 second an error message (the exception at (some hexa number) couldn't read more) and then it went offline just like before... Installing 1.1 and 1.1 sp 1 won't do the trick, at least not for me. – Octavian Mărculescu Mar 10 '13 at 0:27
  • In that case I am not sure :( Sorry I couldn't help. – tmwoods Mar 10 '13 at 0:37

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.