I cannot disable IIS. I've tried uninstalling everything I can think of realted to it including MS Web Deploy, Web Matrix Platform, IIS express (am I missing anything?).

I tried disabling the related services, and I even tried net stop was /y at the command prompt.

All I get when I try localhost is HTTP Error 404. The requested resource is not found.

Even redirecting localhost to a different IP in my HOSTS file doesn't do anything, which used to work fine before I made the ill-fated decision to play around with Microsoft Web Matrix and IIS.

It seems to have hijacked my computer pretty good, and I've tried every thing I can think of to get it removed. Any help?

migrated from stackoverflow.com Mar 10 '13 at 12:44

This question came from our site for professional and enthusiast programmers.

  • did you look at what services are running on the machine? use netstat to see process is bound to port 80? IIS is generally disabled via the "turn windows features on or off", it is not "uninstalled". – Marc B Mar 8 '13 at 17:55
  • net stat just says TCP state listening. I already disabled it via turn windows features on and off to no effect. – JPR Mar 8 '13 at 17:59
  • I mean it's bad enough that I'll put a bounty up when it's eligible. I've tried everything I can think of. – JPR Mar 8 '13 at 18:02
  • the PID is system btw – JPR Mar 8 '13 at 18:05

Your Answer

By clicking "Post Your Answer", you agree to our terms of service, privacy policy and cookie policy