I used to be able to drag and drop files to some of my desktop icons (e.g. Notepad++, AstroGrep, etc.) to open them with the applications represented by those icons.

About a month ago (can't recall exactly when this happened), the system stopped supporting this feature and now it won't do it anymore. Instead, it would only "Move to Desktop" the dragged-and-dropped file.

Any idea how to restore this (very convenient) functionality?


  1. It's not that drag & drop stopped completely. It's only the open feature (within drag & drop) that stopped working for some reason.
  2. This feature works fine on all my other Windows 7 computers.
  3. Deleting and re-creating the Desktop Icons/Shortcuts doesn't help.
  4. I found quite a few postings on "drag & drop not working on Windows 7 64-bit" but they don't really apply in my case because other than having lost the ability to open a file using drag & drop, copying & moving files using drag & drop still works.

Additional information:

I used CCleaner to analyze (only! not "fix"...) possible registry problems and the the only area that may seem relevant is the following "Missing Shared DLL" in HKLM\SOFTWARE\Microsoft\Windows\CurrentVersion\SharedDlls:

C:\Program Files (x86)\Hewlett-Packard\HP Health Check\Tools\UninstallHPSA.exe

Do you spot anything above that may explain this problem?

Update 1:

Neither sfc /scannow nor regsvr32 "C:\Windows\System32\shell32.dll" (suggested below) work. System restore is not an option right now.

Update 2:

I tried the following possible fixes suggested by the link @harrymc provided:

1. Click on any file with the left mouse button and keep the button held down. Now press the Escape key. Didn't help.

2. Disable the "Drag-drop" in Context menu options, apply it then enabled it again. Didn't help.

Clarification: Dragging & dropping to applications while they are open still works. The only thing that stopped working is opening a document/file through a desktop icon.

Also, if I try to drag & drop using the right mouse button, the "Open" context-menu item is not listed:

enter image description here

Additional ideas?

  • 1
    what happens if you start dragging a file, while doing that press windowskey+D then drop the file on a desktop icon? do you get the "+" icon while dragging a file over an icon?
    – weberik
    Mar 14, 2013 at 15:36
  • @weberik I get the same exact behavior. No, I don't get the "+" icon (since the file I am dragging is on the C: drive anyway). This is weird. It used to work.
    – Withheld
    Mar 14, 2013 at 15:51
  • 1
    Questions: (1) Does the problem exist for all icons ? (try with an icon for notepad). (2) Have you run a registry cleaner sometimes before you noticed the problem?
    – harrymc
    Mar 14, 2013 at 17:10
  • 1
    @Daniel I mean if you drag a file to a start menu item (which is technically also a shortcut) or a shortcut shown in Windows Explorer, will the file be opened by that program?
    – Alvin Wong
    Mar 16, 2013 at 6:23
  • 1
    How about you drag with the right (opposite of left) mouse button?
    – Alvin Wong
    Mar 19, 2013 at 14:32

5 Answers 5


I believe this may be a problem in the registry. In particular, I think this lies under HKCR.

I would like you to check some registry data manually first.

WARNING: Editing the registry can be dangerous. You are warned!

First, fire up Registry Editor (run regedit.exe from the start menu search box).

Then navigate to HKEY_CLASSES_ROOT\.exe. On the right you should see (Default) of type REG_SZ having the data exefile. Comment below and stop here if this is not on your machine.

Then also navigate to HKEY_CLASSES_ROOT\.lnk. On the right you should see (Default) of type REG_SZ having the data lnkfile. Comment below and stop here if this is not on your machine.

If you passed the above check, then you can follow the following steps to attempt to fix the problem.

WARNING: Editing the registry can be dangerous. You are warned twice!

The following fixes .exe files:

Navigate to HKEY_CLASSES_ROOT\exefile\shellex\DropHandler. On the right you should see (Default) of type REG_SZ, but may not be having the data {86C86720-42A0-1069-A2E8-08002B30309D}.

Now, select "File" -> "Export" on the menu to backup the data.

When you've done exporting the data, you should try editing the data of the item (Default). Double-click on (Default), then paste the following value {86C86720-42A0-1069-A2E8-08002B30309D} and click "OK" (or press Enter).

The following fixes .lnk (Windows shortcuts) files:

Navigate to HKEY_CLASSES_ROOT\lnkfile\shellex\DropHandler. On the right you should see (Default) of type REG_SZ, but may not be having the data {00021401-0000-0000-C000-000000000046}.

Now, select "File" -> "Export" on the menu to backup the data.

When you've done exporting the data, you should try editing the data of the item (Default). Double-click on (Default), then paste the following value {00021401-0000-0000-C000-000000000046} and click "OK" (or press Enter).

After that, close Registry Editor and restart explorer.exe. The easy way is to log off then log in.

By default, you can also drop to .bat, .cmd and some more file types. If you find that you can't also, find a working Windows 7 machine and copy the corresponding registry values.

  • Thanks! I checked the exefile\shellex\DropHandler and it is exactly as should be. Then I checked the lnkfile\shellex\DropHandler and instead of what you listed above {00021401-0000-0000-C000-000000000046}, I have {83D96563-DB11-42DF-92F9-32CE7BA54ED8}. Could that be the problem? I will try that the moment I can take a break from the current task I am in. Thanks!
    – Withheld
    Mar 19, 2013 at 15:46
  • 6
    And... being curious that I am, I couldn't resist Googling this {83D96563-DB11-42DF-92F9-32CE7BA54ED8} value and, sure enough, it seems to belong to Altova XMLSpy, which is exactly what I installed on Feb 26, and this is more or less when problem started... I will report back when I can verify the change.
    – Withheld
    Mar 19, 2013 at 15:51
  • 2
    Success! and by the way, I didn't have to restart explorer.exe (or logout) for that to start working. THANK YOU!!!
    – Withheld
    Mar 19, 2013 at 19:11

most of the "drop targets" are handled by shell32.dll. you could try to re-register that file by issuing the command:

regsvr32 "C:\Windows\System32\shell32.dll"

then reboot and check if the problem still exists

just a wild guess, but maybe it helps

  • What are the side effects of this de-registration of shell32.dll? Does this apply to 64-bit Windows 7 as well?
    – Withheld
    Mar 15, 2013 at 11:40
  • 1
    well 'de'-registering will probably destroy your system if its even possible. thats why i employ you to 're'-register it, which should have no side effects at all :). it should work for 64 and 32 bit OSs
    – weberik
    Mar 15, 2013 at 11:57
  • Oops... sorry, I meant to write re-registration. :) So, if I understand you correctly, I can safely attempt to re-register shell32.dll without further side-effects, right? Or better yet: Is there a way to only check if shell32.dll isn't registered?
    – Withheld
    Mar 15, 2013 at 12:15
  • its safe, i tried it yesterday and my computer still works ;). there is no easy way to check if its 100% correctly registered. btw your "missing shared dlls" have no effect on your windows shell.
    – weberik
    Mar 15, 2013 at 12:38
  • OK. I just tried regsvr32 "C:\Windows\System32\shell32.dll", rebooted and... the problem persists. Could that be caused by a Group Policy change by our IT department centrally controlling all our PCs?
    – Withheld
    Mar 15, 2013 at 16:29

Delete and re-create the Desktop Icons/Shortcuts.

  • 2
    Thanks. I tried that but it didn't help.
    – Withheld
    Mar 14, 2013 at 13:58

I believe you have harmed the registry by cleaning it. Cleaning the registry is not a good idea if you do not have a very good knowledge of it.

if none of the other answers fix this weird problem, my suggestion is to use System Restore to rollback Windows to a previous System Restore point dating from before the problem.

For more info see Using Windows 7 or Vista System Restore.

  • I didn't use CCleaner to clean the registry. I only used it to get rid of unneeded files.
    – Withheld
    Mar 15, 2013 at 11:37
  • 1
    But something happened which might be impossible to ferret out without System Restore, although the registry destruction might actually have been caused by one of your installed tools. Question: When you drag a file over the notepad icon, does the cursor change from having a "+" to having an arrow?
    – harrymc
    Mar 15, 2013 at 13:29
  • 1
    Try also the suggestions listed in this thread.
    – harrymc
    Mar 15, 2013 at 20:32
  • 1
    Do you have an enormous number of icons on your desktop? Have you installed any desktop organizer tool? (In any case, CCleaner is still a possibility if it cleaned out files from c:\windows.)
    – harrymc
    Mar 19, 2013 at 13:35
  • 1
    Yes, weird is the word. I regret to say that I still think that system restore is the only practical solution, unless someone comes up with a better idea.
    – harrymc
    Mar 19, 2013 at 15:12

Try using the "System Restore" , utlity of windows 7 , that is if you already have enabled and configured it to save restore points frequently. Assuming you had it running , just open system restore first.

In start menu type System Restore ,and then click on the utility. A wizard comes up , follow the steps , and select the date at which , you knew for sure , that everything was running fine , and after the restart , hopefully everything is fixed.


The problem seems to be maybe due to some corrupted system files.

There is a tool called System File checker , which checks the integrity of the system files , this has the possibility determine the cause of the problem. Here is microsoft's support, with regard to that utility.

  • Unfortunately System Restore isn't an option for me right now since I have installed way too many tools required for my work since then. This may be the last resort in case of a disaster and/or when I have time to reinstall things, but being unable to drag-n-drop to open is only annoying, not a show stopper.
    – Withheld
    Mar 15, 2013 at 11:39
  • @Daniel , can you try running sfc , and see if you can determiner the issue , just see my edit Mar 15, 2013 at 12:38
  • Just finished running sfc /scannow: "Windows Resource Protection did not find any integrity violations." Rebooting after that didn't solve the problem. Going to try regsvr32 now...
    – Withheld
    Mar 15, 2013 at 16:20

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .