1

I'm really frustrated about a problem I have with MySQL on my Mac, it's been like two weeks since it just doesn't start, I even tried creating another user account in my mac, with the same results.

I'm sure it used to work a month ago, and not it won't start. I used to use MAMP for launching MySQL and recently it stopped working.

I ran the following commands with no results:

  1. sudo ps aux | grep mysql # (got no processes running under the name of mysql or mysqld)
  2. lsof -i # (no results)
  3. killall -9 mysqld # still, MySQL not starting

I tried reinstalling MAMP (no luck) and installing XAMPP for Mac, with same result (Apache runs just fine, MySQL won't start).

There is no info within the mysql error logs.

Also I tried installing MySQL by using the MMV MySQL Script shown here: http://code.macminivault.com/

And got this error after the installation:

Starting MySQL
. ERROR! The server quit without updating PID file (/usr/local/mysql/data/Quetzalcoatl.local.pid). /usr/local/mysql/support-files/mysql.server: line 362: pidof: command not found
/dev/fd/63: line 58: SORRY, MySQL IS NOT RUNNING ... THERE MUST BE A PROBLEM: command not found

Quetzalcoatl:valkcrm ed$

Any help would be really appreciated.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.