I'm trying to use Internet Explorer to test a website, but scripts don't seem to be running. This seems like it's an issue on a lot of pages - for example, I tried going to the Acid3 page, and it said I needed to enable scripting. I checked my security options, and Active Scripting is set to enabled in the Internet zone. I saw a suggestion on a website to try running regsvr32 jscript.dll; I tried that as well, and as a regular user, I got the following message:

The module "jscript.dll" was loaded but the call to DllRegisterServer failed with error code 0x80004005

When I ran that command as administrator, the registration succeeded. However, Javascript still doesn't work.

Any ideas?

  • Which version of IE and Windows? If you can easily reconfigure any custom settings, perhaps you can try a full reset? Also, an sfc /scannow might not be a bad idea. – Karan Mar 13 '13 at 5:12
  • Did you ever solve this issue? I tried the answer by SnakeDoc but that didn't help with the Javascript issue. – undetected Dec 8 '15 at 15:40

in internet explorer go to:

Tools --> Internet Options --> Advanced --> Click "Restore advanced settings" --> Click "Reset" --> Click "OK"

restart internet explorer and should be back to normal.

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.