28

When I copy the following URL from FireFox
https://example.com/away.php?to=http://example.com/page/42

and then paste, I get a link like:
https://example.com/away.php?to=http%3A%2F%2Fexample.com%2Fpage%2F42

How do I get the non-encoded link instead? Maybe there is a hidden option in Firefox, or a plugin. I tried searching the web, but didn't found anything.

Update re. duplicate question thing:

I am asking not (only) about copying text from address bar, but about copying the text from anywhere in a web page. But let's keep the link between these questions, they seem relevant.

13
  • I don't experience this with Firefox. What version are you using?
    – Dave
    Mar 13, 2013 at 14:39
  • @DaveRook 19.0.2 Mar 13, 2013 at 14:52
  • Are you copying this from the address bar in a browser or from the page itself (eg, copying a link)?
    – Dave
    Mar 15, 2013 at 9:14
  • @DaveRook I'm copying a link from a web page. When i hover mouse over it, the correct link is displayed at the bottom (status bar, or what's its name), but the result is encoded link. Mar 15, 2013 at 14:32
  • 1
    The encoding you see is because the website has actually rendered it like that. The reason it's removed when you hover the mouse over is because your browser is choosing to display it differently, but when you copy and paste, that has nothing to do with the browser per se (hence why same issue occurs in notepad).
    – Dave
    Mar 15, 2013 at 14:36

3 Answers 3

34

In about:config set

network.standard-url.escape-utf8: false

After this path copied as not encoded. But ancor keep encoded. :(

UPD:

Found updated config Value

The setting was replaced with browser.urlbar.decodeURLsOnCopy in Firefox 53+.

https://superuser.com/a/1255451/17118

3
  • 5
    I've tried this, but nothing happens. The copied url still be encoded
    – phuclv
    Sep 27, 2013 at 0:39
  • 1
    No such option anymore in Firefox 60
    – soshial
    Jun 12, 2018 at 9:33
  • Thanks! Works for me (copying from the location bar) in Firefox 86.0 on macOS Big Sur. Mar 17, 2021 at 16:02
16

A work around is to not copy the entire URL from the bar (this works in firefox). And then it wont encode it.

I found that in firefox, if I placed my cursor in the address bar and press 'CTRL A', 'CTRL C', and then Paste it into whatever (an email, notepad++ etc). Then the url would change from what was originally in the URL.

EG.

http://example/test.php?p=(999)+999+999

Would become:

http://example/test.php?p=%28999%29+999+999

But if I copied from the 'x' in example:

xample/test.php?p=(999)+999+999

The URL was not changed on paste and it was easy to fix the front of the URL.

Hope this clears it up.

2
  • 6
    In a previous question (this one is marked as duplicate), an answer posted by @m4573r says that you can edit the URL in the address bar (by adding and then removing a character), and the copy-pasting should preserve the encoding!! :))
    – Nostromov
    Sep 6, 2016 at 23:48
  • 1
    This also works in Chromium/Chrome
    – Ruslan
    Oct 15, 2019 at 13:28
7

Edit

It appears as of Firefox 60 it is no longer possible via the methods in this post, but I'll leave the post for historical reasons...


Open the config page in Firefox by typing in about:config, then promise to be careful and enter.

Type network.standard-url into the search box.

Ensure both values are set to true.

enter image description here

Source

Edit

As per mmv-ru comments, setting escape-utf-8 to false helped. So I assume keeping encode set to true!

6
  • 2
    Yes, they are both already true. Mar 13, 2013 at 16:44
  • 3
    For me, help set escape-utf-8 false Sep 6, 2013 at 14:46
  • @mmv-ru Thanks for suggestion, I'll try it when at home. Sep 6, 2013 at 16:01
  • @mmv-ru Works like in a dream. If you want, you can post this as answer and I'll accept it. Sep 6, 2013 at 17:26
  • No such option anymore in Firefox 60
    – soshial
    Jun 12, 2018 at 9:33

Not the answer you're looking for? Browse other questions tagged .