6

How may I get Explorer to preview .m3u files as text? I have tried Windows 7 - Preview other file types as text in Preview Pane and carefully checked, but no joy.

I got no success with .m3u using PreviewConfig:

1

or the manual method too:

2

1
  • I assume you have tried to use the suggested tool, PreviewHandlerEditor.exe, as per the linked question?
    – Ramhound
    Commented Sep 5, 2017 at 14:36

3 Answers 3

5
+50
  1. Start >> Regedit.exe

  2. Find HKEY_CLASSES_ROOT\.m3u key and check the 'Default' setting (in my case VLC.m3u)

enter image description here

  1. Find HKEY_CLASSES_ROOT\VLC.m3u (in this path substitute VLC.m3u with the value of your default setting in HKEY_CLASSES_ROOT\.m3u)

  2. Create a new key in HKEY_CLASSES_ROOT\VLC.m3u: shellex

  3. Then in HKEY_CLASSES_ROOT\VLC.m3u\shellex also a new key: {8895b1c6-b41f-4c1c-a562-0d564250836f}, so it should look like this:

enter image description here

  1. The {8895b1c6-b41f-4c1c-a562-0d564250836f} key tells Windows that you want to use a preview handler, now you only should specify which one you want to use. Set HKEY_CLASSES_ROOT\VLC.m3u\{8895b1c6-b41f-4c1c-a562-0d564250836f} Default to this value: {1531d583-8375-4d3f-b5fb-d23bbd169f22} (text handler ID)

  2. If you want to use other handlers in shell you can find their ID's in the following key: HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\PreviewHandlers

6
  • Thanks, but that failed. i.imgur.com/RhpBmly.png , i.imgur.com/3hOWllR.png , i.imgur.com/sDoaOeb.png . I was surprised to see Media Jukebox there., because .m3u Open launches Textpad.
    – ChrisJJ
    Commented Oct 10, 2015 at 13:09
  • @ChrisJJ That is beacause you've already modified you registry with Previewconfig (and possibly you manually edited it, too). Revert to the original settings, and only apply the modifications I suggested. This way it should work. Moreover you have no settings in your .m3u key Content Type, and PerceivedType which should be 'audio/x-mpegurl' and 'audio' respectively. When a file's content cannot be determined windows handles it as text by default.
    – anghra
    Commented Oct 12, 2015 at 8:30
  • I made those changes i.imgur.com/UmF5rea.png. I don't know the original settings. Would you like to add the further required settings to your solution?
    – ChrisJJ
    Commented Oct 12, 2015 at 19:47
  • try deleting the three 'MediaJukebox.14.xxx' keys. (these were probably made by Previewconfig) Otherwise I have no further idea :D
    – anghra
    Commented Oct 12, 2015 at 23:31
  • Done i.imgur.com/hP18siK.png but no joy. Thanks anyway for trying.
    – ChrisJJ
    Commented Oct 14, 2015 at 0:26
0

In Media Jukebox, uncheckmark the m3u File Association

enter image description here

The clue that led me here was the Note in the PreviewConfig image above - despite that nothing on that Media Jukebox dialog suggests the association affects more than Open, and Open on a .m3u does not invoke Media Jukebox, but instead Textpad.

Oddly, recheckmarking the File Association does not restore the issue i.e. preview continues to work.

-1

right click the file -- > open with --> choose notepad from the list of programs, then put a checkmark in the "open future files with this program" (or whatever it says to that effect)

2
  • 2
    Thanks, but that does not affect the preview.
    – ChrisJJ
    Commented Mar 14, 2013 at 1:33
  • whoops! missed that... not sure on how to change the preview... sorry.
    – SnakeDoc
    Commented Mar 14, 2013 at 1:36

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .