For now I've been using Paint Tool SAI for drawing, but I bought Adobe Photoshop CS6 lately and I noticed intolerable lagging while drawing with standard brushes. Delay is even bigger when I choose '3D' brushes. My PC specification:

  • 6-core 3.7GHZ AMD CPU
  • 24GB DDR3 RAM
  • 2x128GB Samsung SSD in RAID 0 config
  • 4x2TB WD Caviar SATA III HDD in RAID 1+0 config
  • nVidia Quadro 2000 with three full HD screen
  • Windows 8 Pro

I'm using Wacom Intuos4 with standard pen. Photoshop and all drivers are up to date. And the hardware acceleration in PS is enabled. CPU usage is never bigger than ~5% while drawing, and canvas size is about 3000px square. I was seeking through all performance settings in Photoshop and I have no idea what I'm missing, especially that my computer isn't the slowest one...

  • Bro, ur pc is just mind-blowing ... !! does it roar while working? ... :P – kmonsoor Apr 4 '13 at 12:25

photoshop runs has many performance factors which you have to look into when using it .

  1. The dpi and the resolution of the photoshop file matters anything above 200 dpi 2000x2000 resolution may start to lag

  2. scratch disks : these are like virtual memory the photoshop uses . please make sure it is using the hard disk which has adequate space.

  3. amount of ram : please make sure the min and max amount of usable ram is set properly in the preferences .

  4. 3d brushes require you to enable the openGL option as my friend above has mentioned . make sure you enabled it .

|improve this answer|||||

3d relies on graphic card power be sure to enable OpenGL on nvadia.If you still have problem reset photoshop. also tried changing the tile size to 128K instead of the default 1024K.

|improve this answer|||||

I was just having a similar problem. PS CS6 would lag when brushing, like it was stuttering. After checking my Event Viewer in Win7, going to Event Viewer>Windows Logs>System I found that one of my disks was constantly throwing out errors. That disk was a SSD that I had set aside as a scratch disk for PS. As soon as I changed the scratch disk inside the preferences of PS to another drive the issue resolved itself.

|improve this answer|||||

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.