I had a VMWare Fusion VM backed up on my home network file server (Ubuntu). I wanted to run it again, so I copied it back to my Macbook.

When I tried to launch it in VMWare, I got an error message:

No permission to access this virtual machine.
Configuration file: /Users/craig/WinXP Clean + Scanner.vmwarevm/WinXP Pro Test.vmx

The permissions look fine to me:

  • The bundle directory is 777
  • The bundle files (including the listed .vmx) are all 666
  • User is craig (my current user); group is staff. I changed the group to wheel at the suggestion of this page, but that didn't help.
  • Finder shows read & write for craig, staff, and everyone on the bundle directory
  • The bundle dir is also not locked
  • Finder also shows rw and unlocked for the .vmx file
  • The parent directory is also rw & unlocked
  • Disk Utility permissions check doesn't show any problems with any of the associated files

It sure looks like I should have wide open access to run this VM; why is Fusion complaining?

  • Have you got any Access Control List (ACL) set. Try the -e option to ls to see – user151019 Oct 18 '09 at 10:59
  • It does not appear so, as best as I can tell – Craig Walker Oct 19 '09 at 21:35

Are you the owner of all the files in the bundle recursively? At this discussion (at post #6), a solution to this problem is to run the following in Terminal:

sudo chown -R ${USER} "/Users/${USER}/Documents/Virtual Machines/Windows XP Professional.vmwarevm"

You'll need to replace Windows XP Professional.vmwarevm with WinXP Clean + Scanner.vmwarevm in your case.

Also, keep in mind that repairing disk permissions will never repair anything in your home directory. It's only applicable for Apple-installed software that are listed in /Library/Receipts.

| improve this answer | |
  • Good advice, but unfortunately it didn't work for me. – Craig Walker Jan 17 '10 at 20:57
  • Hmm, not sure then. I wonder if there is a hidden xattr setting deep within the VM that was lost during the transfer to/from your Linux file server (which I'm guessing is ext4). Judging by the @ symbol on the end of the permissions for each file inside the vmwarevm bundle on my disk, I'm assuming that VMware must be using a bunch of xattr values for something. – fideli Jan 17 '10 at 22:35

I had the same problem occur on my VM. Mine sounds like it was probably a different underlying cause than the original poster's, although the error message was exactly the same.

It turned out that I had a *.vmx.lck directory inside the bundle that must have been left over from an old execution. As soon as I deleted that directory, the problem went away and the machine was happy to start again!

| improve this answer | |

It looks like you're using vmware-run to start the VM ? Not the fusion UI (I'm interpreting the copy-n-paste text in your post).

This might be the same problem as VMWare Fusion 2.0.6 no longer wants to load my VMs - my advice there may apply here.

| improve this answer | |
  • Nope, I am trying to use the fusion GUI. The copy-n-paste text is actually carefully-retyped text :-P Thanks for the link though; I'll try that and see. – Craig Walker Nov 4 '09 at 15:40

I called up VMWare Tech support to get a solution for this. After some very helpful investigation by the VMWare Tech, we eventually got it working by creating a new VM based off of the old virtual disks.

The tech speculated that copying the files off my Mac to a Samba share might have caused the permissions to become improperly set. He mentioned that copying files onto and back from a FAT volume (with its rudimentary permissions system) can occasionally fix problems like these.

| improve this answer | |

I've had a similar problem in getting an old vmware workstation image to work on the current vmware workstation software. What I finally figured out from a similar cryptic message was that ACE had been enabled on the old image. Fortunately, I had the old vmware software and was able to strip ACE out of the vmimage. Then things worked fine on the new workstation software.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.