At some point a few days ago the speakers on my Lenovo Thinkpad T410 (Model number: 2537A11) suddenly stopped working randomly. This error happens every time I watch a video or listen to a music file. The sound just abruptly stops. At the moment, I can't produce a single sound no matter what I do. I am using Debian GNU/Linux on this laptop and there doesn't appear to be anything else wrong (the fan is working, no abnormal heat (staying around ~40°C), no other obvious errors or problems).

Here is the output of a nice program someone pointed me to:

martin@martin:~/Downloads$ sudo python run.py --monitor
Using temporary directory: /dev/shm/hda-analyzer
You may remove this directory when finished or if you like to
download the most recent copy of hda-analyzer tool.
Downloading file hda_analyzer.py
Downloading file hda_guilib.py
Downloading file hda_codec.py
Downloading file hda_proc.py
Downloading file hda_graph.py
Downloading file hda_mixer.py
Downloaded all files, executing hda_analyzer.py
Watching 1 cards
Sound is working normally and then it stops and the following lines appear:
Diff for codec 0/0 (0x14f15069):
@@ -164,17 +164,17 @@
   Power: setting=D0, actual=D0
 Node 0x1f [Pin Complex] wcaps 0x400501: Stereo
   Pincap 0x00000010: OUT
   Pin Default 0x901701f0: [Fixed] Speaker at Int N/A
     Conn = Analog, Color = Unknown
     DefAssociation = 0xf, Sequence = 0x0
     Misc = NO_PRESENCE
   Pin-ctls: 0x40: OUT
-  Power: setting=D0, actual=D0
+  Power: setting=D3, actual=D3
   Connection: 2
      0x10* 0x11
 Node 0x20 [Pin Complex] wcaps 0x400781: Stereo Digital
   Pincap 0x00000010: OUT
   Pin Default 0x40f001f0: [N/A] Other at Ext N/A
     Conn = Unknown, Color = Unknown
     DefAssociation = 0xf, Sequence = 0x0
     Misc = NO_PRESENCE

And now there is also an error in the dmesg output

hda-intel: IRQ timing workaround is activated for card #0. Suggest a bigger bdl_pos_adj.

I changed the bdl_pos_adj to various numbers (-1, 0, 64, 1024) and either there is no change at all or dmesg reports that the adjustment is too big. I wonder if this bdl_pos_adj is the real reason for the error.

Here is my hardware information provided by alsa-info.sh website.

Okay, i did some serious testing and even installed Windows and now i officially conclude that this is a hard-ware related issue with my Laptop speakers.


  • The error occurs in my installed Debian Linux, an Ubuntu Live distribution and Windows XP
  • No error-message appears in all of the OS. The sound just keeps running and i can't hear a thing.
  • I tested different setups, including OSS, ALSA and the pulseaudio server on top
  • If i use my new usb-headphones i can hear sound all the time without any sudden silences. So obviously, although hard to believe, my laptop speakers are not okay (never heard of similar cases).

I'll award the bounty to anyone who can point me to good tutorials or the procedure how to exchange my T410 speakers (i still have warranty. The laptop was bought in Germany, but now i am in Denmark). Or to someone who can explain me the output from hda-analyzer (big log above).

  • Relevant? bugs.launchpad.net/ubuntu/+source/linux/+bug/267913
    – terdon
    Mar 21, 2013 at 14:42
  • i found that too (bug from 2008), but i don't believe that this is the real cause. The error even occurs on live-distributions using the newest kernels out there. If it is really a software related error (i am starting to doubt that), than it is related to alsa
    – Curlew
    Mar 21, 2013 at 19:49
  • Yeah that's what it seemed like on the bug report. Dunno, have a read through it, the last entry is from 2012-09-16.
    – terdon
    Mar 22, 2013 at 2:17

2 Answers 2


It is a hardware problem, a design flaw. Supposedly Lenovo changed the fan design with the T420.

Lenovo is aware of the problem and they exchange the motherboard, no questions asked. I am on my way to get the third motherboard. The first had the flaw from the beginning. I tried pretty much everything software related for the first 6 months. Then I talked to a Lenovo dealer, and they said "Yes, we are aware of it." The second motherboard worked for about 6 months.

  • Do you have any written sources for that?
    – Thor
    Feb 1, 2014 at 16:06
  • @Thor Hey, did you ever that written source? I have a Lenovo G460 with the same problem but since I bought it about 3 years ago I'm afraid Lenovo isn't going to acknowledge it as a design flaw and change my motherboard. So I'm trying to get my hands onto any kind of proof I can.
    – TomCho
    Dec 27, 2015 at 0:08
  • @TomCho Unfortunately I never found any written source myself on the subject of that.
    – Thor
    Dec 28, 2015 at 12:23

In my case sounds came back every time after sleep/shutdown. After that I tried

$cat /sys/module/snd_hda_intel/parameters/power_save

So I tried.

echo 1 > /sys/module/snd_hda_intel/parameters/power_savelaptop.

And now sound come back when I stop sources of audio (youtube, amarok, etc) and sound comes back for a moment.

I have opened a ticket in bugzilla, but I have not received an answer yet. There is more detailed info of tests I ran there. https://bugzilla.redhat.com/show_bug.cgi?id=1023830.

  • 1
    I am having difficulty working out if this is an actual fix or if you are simply stating that you have the same problem too.
    – Mokubai
    Nov 2, 2013 at 9:20
  • I agree with @Mokubai - are you confirming that this would be a fix, but there's a bug, or are you simply stating another possible solution that hasn't worked? Nov 2, 2013 at 11:57

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .