-1

I did some "hacking" (well, more like bypassing) and set my router location to "JAPAN", please see this picture:

enter image description here

This allowed me to set my network to channel 14 in the Advanced Wireless Settings.

However, when I set my channel to 14 in the router, no device in my home can detect it.

Even inSSIDer 2.0 cannot detect my network on channel 14.

I think the source of the problem is in the Drivers, I probably have the European/US version of the drivers.

My WiFi card is an Atheros AR5B97 Wireless Adapter, and the current drivers I have are from Qualcomm.

How can I enable "searching" in channel 14?

Does anyone know where I can download the Japanese drivers (if any available?)

I just cannot find them. I tried advanced settings, and looking for anything channel related but without result:

enter image description here

  • 1
    Are you in Japan? Or do you want advice on how to cause interference with other devices using 2.4GHz? – sawdust Mar 18 '13 at 0:49
  • 12 and 13 is allowed here, 14 not really, but I don't think it's going to interfere more than all other networks with my network. – user144773 Mar 18 '13 at 2:04
  • 2
    "I don't think it's going to interfere more than all other networks with my network." -- I was not referring to WiFi networks. If chnl 14 is not allocated for 802.11 in your country, then it's probably allocated for other protocols that also use 2.4GHz, such as 802.15.4 and cordless phones. See also Electromagnetic_interference_at_2.4_GHz, and note comment about ZigBee. – sawdust Mar 18 '13 at 7:13
1

It's likely that your Atheros card is just hardware limited to be unable to access channel 14. From what I remember channel 14 is Japan only and limited to 802.11b.

If you're having co-channel interference from neighbors you might just want to upgrade to 802.11n(or hold out a little longer for 802.11ac) which will allow you more room to breathe.

  • ah 802.11b only, that sums it up pretty much. – user144773 Mar 18 '13 at 11:28
2

The following answer is assuming that you are in the us, I do not know if you are in america, or if you live some where else, if you are not ignore this answer.

U.S. hardware to my knowledge is setup in such a way that prevent you from doing this. As I understand it the drivers are designed to work on channels 1-11. "We" don't use 12-14, if you are attempting to do this custom roms, and such might be your answer; the FCC make it difficult for people to bypass their frequency rules and such.

  • from what I've read the device itself is capable, but the drivers don't "allow" it. I'm in Europe, but there's so much network traffic here at my place I have to "move away" from it and CH14 seems to be the ideal alternative, Channel 13 is available here but still away from perfect. – user144773 Mar 18 '13 at 1:59
0

You can set your router to transmit on channel 14 (not allowed by standard in most countries) but your wireless devices are configured (software or hardware) to listen only to channel 1 - 13. So they won't see channel 14. Either configure your devices to enable channel 14 as well or set your router back to standard.

0

The regulatory region is set in the EEPROM on the network card itself. The drivers read the EEPROM to see what channels and transmitter powers are allowed, and what 5GHz band radar anti-interference is required. You would have to modify the EEPROM on the card or hack the drivers. In GNU/Linux the iw reg set command can be used to force the drivers in to a certain regulatory region.

Only 11b 11mbps maximum DSSS/CCK modes are permitted on Channel 11, and only in Japan. All Wi-Fi hardware is perfectly capable of operating in DSSS/CCK mode, but with 11b being obsolete, most everyone would want to use the faster 11g modes on channels 1 to 13, so I would imagine that there is little demand for using channel 14 today even in Japan.

In theory you should be able to connect to an access point that is on a forbidden channel, since the presence of that access point shows that you are traveling to a region where the extra channels are allowed. But Wi-Fi clients send out probe requests on all channels to speed up scanning and to be able to connect to "non broadcasting" access points that don't include the SSID name in their beacons. The makers of the drivers probably didn't want to go to the extra trouble of adding an option to enable the additional channels and creating a partially working implementation that scans the additional channels without sending probe requests.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy