Due to living in a multistory house, we use powerline (homeplug) adapters, which in principle works fine. We have several restrictions though:

  1. All powerline adapters currently in service have only one LAN port/outlet.
  2. We don't want to shell out money for a new ">1 LAN-port" powerline adapter, because:
  3. I already own a working switch and want to use it.
  4. I can't attach the switch to the router, but multiple devices need to be attached to the switch

For these reasons (being on the 2nd/3rd floor with multiple devices), I am forced to connect the (Auto-MDI/MDIX -activated) gigabit switch (TP-Link "TL-SG1005D") to what is probably internally configurated as "outlet" or "agent" by the powerline (devolo "dLAN® 200 AVsmart+") software? Result: It doesn't work.

I wouldn't have to care about all this if I'd use a desktop PC, but:

  1. I use a laptop with the above setup, which has only one (Gigabit-)LAN port
  2. Buying an expensive laptop docking station just for a 2nd or 3rd LAN port is not an option

Visual network layout: (PLA = powerline adapter) enter image description here

Troubleshooting/solutions that I tried (unsuccessfully):

  1. Obviously I made sure that the powerline adapters are plugged directly in the wall as is advised to do
  2. I checked powerline producer website: Adapters are explicitly switch-compatible (but as an agent?..)
  3. I e-mailed to the support team of the powerline hardware: Still waiting...
  4. I updated the firmware of the powerplugs and checked my own Intel LAN laptop drivers (up to date)
  5. The gigabit switch has no firmware update possibility, but I reset its power
  6. I deactivated and reactivated my laptop's LAN adapter and tried with a fixed IP
  7. I am a 100% sure my GB-switch (still) works, as the transfer (cable and endpoint-wise) between my laptop and my "NAS" (drobo) does indeed work.
  8. I searched through Google + SU: Found several existing threadss, but none comparable to my setup.

Bonus question: If I'd alternatively connect my drobo NAS to a - spare - (W)LAN powerline adapter, could other people in the same house (i.e. people that use the same router-connection via powerline!) connect to its contents via the powerline LAN or WLAN as I myself plan to do? Normally people worry about neighbors (which is no problem), but in my case I (have to) worry about the people inside our network.

  • What happens when only the laptop is connected to switch, which is then connected to PLA? This config is essentially identical to laptop connected directly to PLA (i.e. a switch does not alter Ethernet frames). If this connection fails, then retest the switch and all cables.
    – sawdust
    Mar 19, 2013 at 2:02
  • Thanks for asking, that is exactly the configuration which I tried and aim to get working, but that doesn't work. Which (3rd) alternative to the two scenarios you described do you see? Mar 19, 2013 at 2:05
  • The only potential cause for this issue I can guess is: 1. Some "network cache" on my laptop that needs to be emptied?? (i.e. my laptop is highly likely the one not accepting the connection) or 2. the problem is with the fact that the switch is NOT directly behind the router (i.e. not positioned before the first PLA), but behind two PLA's (which are - naturally both "behind" the router)? Mar 19, 2013 at 2:07
  • 1
    The switch is invisible to upper layers of the Ethernet protocol. If you can ping the router when the laptop is connected directly to the PLA, but ping fails when the switch is in the path, then the first concern is to be absolutely sure that the switch and cables are good. There are no "network cache" or "not behind" issues involved in this problem. Even wireless access points that allow only 1 wired client will work with a switch (but only one host connected to that switch).
    – sawdust
    Mar 19, 2013 at 2:19
  • I have the details (access data) for the router that accesses the internet for us lying next to me, but can you refer me to a tutorial of how to "ping"? (Is that one sufficient: youtube.com/watch?v=6VRvs-TQSWM) Mar 19, 2013 at 12:17

4 Answers 4


I've had a mixed homeplug network consisting of a 500mbps/4 port gig-e switch and a pair of 200 mbps non passthrough adaptors. Its reasonably similar to yours I've found a few things troubleshooting it. You can see a somewhat stripped down network diagram in my answer here

Firstly that not all adaptors in the network behave identically - the gig-e switch is significantly more sensitive to noise (though I have no idea to whether this is due to it being in a mixed network, or inherently sensitive to noise). While useless in most cases if the signal lights report worse than perfect signal, you're probably alright on the power line side of things. Oddly I found its more likely something is wrong with your devices report a perfect signal, but you have connection issues.

As for noise, the only real way to work this out is to go on walkabout - my switch goes down whenever one of our washing machines run (the 200 mbps gear has signal degradation). The troubleshooting methods available on homeplug gear is rather useless - in my case the switch reports perfect signal (Its usually red or amber) when it isn't working, and occationally blinks. I started by switching off all other devices in my room, ruled out any changes in the next room and the next when the networking was glitching, and worked my way through the apartment. Focusing on devices with big motors like Fridges and washing machines is a good idea. You can probably add a filter, but I haven't found one for my local plug type. Some people actually use passthrough homeplugs for the same thing, but it seems wasteful. I ended up fixing this issue by moving the homeplug connection further from the devices that gave me issues, and I have had no issues since.

I'd also 'check' to make sure all the homeplugs are on the same private network name - they generally tend to be set to HomeplugAV, but changing it would be a good idea. You can set it with magic everything button Homeplug units have, or use a utility provided by the company that makes them (which tend to not actually tell you what the current network name is, or actually provide any sort of feedback whatsoever). In theory you can also detect what devices are on the network, but practically this works rarely enough (even when I'm on the network, and connected properly) that its pointless.

In your case it was something else, but I'd like to put this out there since anyone looking for my problem or something similar


You can use HomePlug Monitor to get detailed information about your HomePlug line.

enter image description here

It gives you information like connection quality (through signal to noise ratio and bit per carrier values, RX/TX values and raw rx/tx which the standard management applications do not provide.

  • As posted, this answer wasn't very good. Its an awesome app, and I've taken the liberty of fixing it up rather than deleting it. Its something I am certainly adding to my toolkit. Is there a proper website for this app? I'd like to keep track of future updates
    – Journeyman Geek
    May 29, 2014 at 2:31
  • There is no better website than linked one, updates will be commited on this forum page. Apr 14, 2015 at 9:34

Ok, I found my mistake: I had my drobo NAS set to a fixed IP. Letting it receive a DHCP IP solved it.

I had to wait 5-10 minutes though, until all devices got used to the new, proper state.

(Until then, even after my change, both www and my other device didn't yet work concurrently.)

Another two steps I initially forgot to test:

a. Exchanging the devices (and their order) on the switch and b. swapping the dLAN adapters.


Although you haven't advised the symptoms of your problem, it probably makes sense to start at a "lower level".

I postulate that the powerline device may simply not be able to receive a signal from other devices. There are a number of possible reasons for this, including things like distance, but more relevantly different power phases or things like 'RCD's between circuits. (I know in my house powerline devices would only work between certain sockets because of RCD protection - I suspect this is the problem here). To eliminate this as an issue, try moving the powerline devices onto the same circuit and seeing if there is a problem. (If there is, its either a faulty device - or conceivably an encryption/privacy setting - not that I've come across those).

If you have a "flat" network (ie 1 router with your WIFI, ethernet and powerline devices all plugging in to the router - directly or via unmanaged switches - which would be a typical setup for most homes, yes, you would be able to share your NAS with your powerline devices. (Think of a powerline as a slow ethernet cable run between power sockets - they don't do any routing or firewalling). Generally - and simplifying a bit - if you look at all your devices and they have the same IP address range (eg 192.168.1.X), devices can be plugged in to any interface and will see other devices in the same range.

  • Your answer shows me that I may not have been clear: My www connection works just fine when I don't involve the switch. Only if I want to involve the switch to further extend the amount of hardware connected to my laptop / the network itself, then it doesn't work anymore, as the internet somehow doesn't get passed over from the powerline device to my laptop by the switch. Mar 18, 2013 at 22:39
  • 2 Possibilities I can think of - The first being an incompatibility with the switch (Do you have another - preferably 100megabit switch as that is what your powerline devices have that you can try instead ?), or that somehow the additional functionality built into the Devolo tracks/limits the number of MAC addresses visible - although I would be surprised if this is the case.
    – davidgo
    Mar 18, 2013 at 22:54
  • Unfortunately I only have one switch. The devolo technology supposedly supports up to 64 devices at once according to FAQ. I added a visual clarification of my network to the question. Mar 18, 2013 at 23:46
  • 1
    I think you will need to beg/borrow/try another switch to rule out problems related to your switch. Are you able to temporarily take the router in your basement and plug it (lan side only) on second floor and see if other machines plugged into PLA's can access to DROBO in this configuration - ie use the router as a temporary switch. [ Alternatively you should be able to buy a 100 megabit 5 port switch dirt cheap (I'm not int he USA, but Wallmarts webpage advertises a Linksys SE1500 5-Port switch for US$20, and that's without even looking arround]
    – davidgo
    Mar 19, 2013 at 2:47
  • That's a good idea. In fact I have at least two other routers lying around. I just thought that if I plug in a router it will further complicate the setting? Right now I tried to connect the router directly to my laptop (to deactivate DHCP and update the firmware?) via one random LAN-port, but I can't access it, whatever (given) IP address from the manual I use. How do I connect it in a way that my laptop can access it locally? Because as said, I don't have two LAN ports on my laptop. :/ Mar 19, 2013 at 12:14

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.