I have an ASRock Z77 Extreme4 motherboard with Windows 8 (not Pro). Brand-new computer, built from new parts. I use a 600GB drive (10,000RPM) as boot drive (let's call it HD1) and 2 3TB drives in a RAID1 configuration as data drive (let's call it HD2).

One goal with this new computer is to avoid data loss should one of the data drives die on me, hence the RAID. Another goal of mine is to move the entire Users folder to the RAID drive to use less storage space on HD1 and again for data safety, and I found a method that should work just fine, but after spending a couple of days messing with it here's what happened:

I copy user data or other files onto the RAID in command prompt mode using robocopy /copyall /mir /xj, then mklink to create a junction/symbolic link, then I reboot, and I can't log in because my user folders don't exist. Turns out, all or most of the files and folders simply disappear seemingly by random within 20 seconds after rebooting. In one situation, I had copied the Users folder over twice with different folder names (User and User2) just to see what would happen, and after rebooting and opening Explorer I literally watched as first one and then the other folder disappeared.

So my first thought was: Oh, I'm copying the files over while starting in Command Prompt mode, so the RAID drivers are not loaded, so whatever I copy over gets killed because only one drive receives it or something... Can someone tell me if that's possible?

But alas, the same thing happened when I simply used Windows itself to move just my Documents and other user folders over to the new drive (using Properties, Location and Move), and I had also copied all my drivers and installers from a flash drive to the RAID drive using fully booted Windows 8. Again, on reboot, they magically were gone - including all the Users folders.

This last time before the files disappeared, Windows during boot ran a scandisk of the RAID drive. Another thing I'm wondering is if scandisk can even handle the RAID drives without the raid drivers...

So it finds some corruption, fixes it, and then the files are missing - but not all! This time, it left 3 folders inside my profile folder, but my installers were gone, too.

Here's what the Event Log says about the drive:

A corruption was discovered in the file system structure on volume D:.

The exact nature of the corruption is unknown.  The file system structures need to be scanned online.

So maybe these files ALSO disappear during scandisk, but I have literally watched them disappear without scandisk as well...

So my main question is:

What could cause these files to disappear, and what can I do to stop this? It's getting ridiculous and to the point where I'm seriously running out of ideas...

The mainboard does not seem to have an option to turn RAID mode on only for specific drives (unless I'm missing it), so all of SATA is in RAID mode as far as I know. Then the RAID option becomes available before Windows boots, and I have combined the two drives into one RAID1 array, and once Windows is fully installed, it recognizes it properly as one drive, and the storage software for the motherboard (all drivers are downloaded fresh, nothing old from CD) also recognized a properly working RAID.

Is it possibly a bad drive? What easy way is there to run a surface check on both drives? Do I have to turn off RAID mode altogether, boot from the Windows 8 DVD and run scandisk from there, or ... ? Can the Windows 8 DVD even handle 3TB drives? Originally, when I installed Windows 8 for the first time, the drives showed up as 2x 400GB or something like that until I installed the SATA3 or some other storage drivers, so I'm really confused at this point...

I have installed computers and maintained them for over 20 years and have never had that much trouble before. Granted, I am completely new to Raids and Windows 8 (my current computers are XP, and the Win7 machine at work was installed before I got there), so please excuse the big amount of questions - I just don't even know where to start looking for answers anymore...

I spent the last few days experimenting and researching, but can't find anything on the matter.

  • Just started chkdsk /R/B on HD2. Here's a few samples: Deleting orphan file record segment xxxx, Deleting index entry $RECYCLE.BIN in index $I30 of file 5., Inserting an index entry into index $0 of file 25., Correcting error in index $I30 for file 71., Sorting index $I30 in file 71., Recovering orphaned file AXTU(v0.1.257).zip (73) into directory file 71. and finally Skipping further messages about recovering orphans. Not sure, but doesn't really sound like bad clusters, more like the file system is being messed up, but still no clue by what... Commented Mar 19, 2013 at 2:30
  • Finished chkdsk, running it again just out of curiosity - and I think it is listing the exact same errors again... Should I not have installed the sata and raid drivers from the motherboard site and rather have gone with what Windows 8 installed by itself? Is there a setting I might have messed up? Commented Mar 19, 2013 at 12:36
  • Wow, this one is new: The disk does not have enough space to replace bad clusters detected in file 1800 of name . - this is a 3TB raid that has never had more than 1GB of data on it ...... So ... does this actually mean that my hard drives ARE bad? Can I trust any of this at this time? Isn't Raid1 supposed to work even if one drive is dead? confused Commented Mar 19, 2013 at 12:38
  • 1
    OK, after attempting some more research and talking with my boss who knows more about raids, I have decided to scrap the idea of using a raid. It has caused me nothing but trouble, and the only advantage is instant "backups" - so I'll separate the disks and run nightly backups - done. I am leaving the question open in case someone would like to add some insight to it for others with similar issues, but if I don't see activity here after a few days, I'll just close it. Thanks to everyone looking and upvoting :-) Commented Mar 19, 2013 at 14:01
  • You certainly have had some pretty strange problems here… FYI I have been using RAID arrays for nearly a decade now, and have never experienced something like this before. Personally, I would have backed up the data, broken the RAID, examined the drives with the manufacturer’s utilities, done a Spinrite on them for good measure, and then rebuilt a brand new array and tested that extensively before putting data back onto it. However, I think that the problem may have been more than just a bad RAID setup, you might also want to look into NTFS corruption. Commented Jun 15, 2013 at 1:31

1 Answer 1


Normally your BIOS, if properly configured, should have a RAID submenu you can access during boot time (it's not part of the regular BIOS setup screens). It's from that menu you choose which drives you want to be part of a RAID array and the motherboard will build the RAID 1 array before Windows even boots.

If you have RAID enabled, when it scans your drives, you should see a line with something like "press F5 for RAID options." It might be you missed that in your setup? You may have to change your BIOS POST settings to display more info during boot (i.e. turn off any "fast boot" options).

Check the manual for your motherboard for specific instructions on configuring RAID arrays for your system. If you don't have a manual, you should be able to find it online.

If it's an Intel RAID controller on the motherboard (often part of the CPU chipset) make sure you have the correct Intel Rapid Storage drivers. If it's a third party RAID controller, Google it and find out what the best drivers are.

Newer UEFI PCs behave differently than older BIOS systems did. If you're not familiar with UEFI you might want to read up it. Here's one resource: http://www.extremetech.com/computing/96985-demystifying-uefi-the-long-overdue-bios-replacement

If you're still having problems, you might also see if a BIOS update is available. But, if you've never set up your RAID array before Windows loads, that's very likely your problem.

If you're worried you have a bad drive, try testing each drive individually with the other drive removed from the system. Normally once a RAID 1 array is properly configured in BIOS it will check the drives at every boot and warn you if a drive is reporting errors.

Finally, you're wise not to try to install Windows on a RAID array. There are often headaches with that--both getting it working and down the road with things like restoring backups, drive upgrades, etc.

  • I am fairly certain that I had set it up correctly. I used the just-after-POST-but-before-boot RAID menu to setup the raid on two identical hard drives. Windows booted normally and detected the secondary drive. But it kept deleting files and logging corruption errors. The same drives have been working normally and without issues by themselves for over a year since I gave up on the RAID. I think the motherboard IS UEFI, but I thought I had tried all the options it gave me. I even read some of the manuals, confusing as they were (I usually don't). Thanks for your answer. Commented Mar 9, 2015 at 13:42

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .