I've got three iMacs here (one mine, two from others), which should all connect through SSHFS with a MacFusion client to a CentOS server. I've been trying to get it all working with my iMac, which eventually worked. I managed to connect through MacFusion to my own unix account and get into my home directory.

When the others are trying this, this fails with message "Authentication failed". I've tried using their credentials on my installation of MacFusion, and these simply work. Looking in the server's /var/log/secure it only shows me the following on their connection:

Mar 19 08:03:10 10 sshd[5129]: Connection closed by

It seems that their client does not even push the credentials through.

I first made them install OSXFuse, which gave them the error Mount process terminated unexpectedly, which I could fix with this article. (I did this as well, so there should be no inconsistencies here) So now we're all running on older MacFUSE version 2.1.9.

I've also tried to lock their Keychain to prevent them from loading those up, but also this does not seem to relieve the problem.

Anyone got any clue on what's going on?

  • 1
    -1: I can't figure out exactly what you're asking. – killermist Mar 29 '13 at 16:38
  • I wouldn't really know how I could further explain the situation. Any extra details I could provide? – Ambidex Mar 31 '13 at 12:33
  • Jester87's suggestion gets you on the right track. If you can't ssh into the box, you can't mount it. Try sshing from the various machines with your credentials, using the ssh -vv flags; that'll give you verbose output, and show if a connection is being started, if keys are being exchanged, and hopefully a clearer picture of if you're able to hit the boxes in the first place. – Stephan Apr 2 '13 at 19:53

It sounds like there are some problems with permissions and/or firewall settings. Check to make sure the users on the linux server are authorized.

See http://wiki.centos.org/HowTos/Network/SecuringSSH

Also you may want to check your OSX firewall settings to see if the macfusion is somehow blocked.

I'd also try using a terminal and connecting via SSH to see if that works at a very basic level.

  • Hi @Jester87, thanks for your response! You know what the weird thing is? They are able to mount the SSHFS by doing: $ sshfs -o follow_symlinks [username]@ /Volumes/SSFSMount. Which suggests to me there shouldn't be a problem with authenticating server-side? I don't think a firewall is causing problems, but I'll go look into that. – Ambidex Apr 3 '13 at 8:13
  • Apparently there is no firewall whatsoever active on the desktops. Also we've tried to connect at the most basic level ssh -l [username], that simply works... – Ambidex Apr 3 '13 at 13:31
  • Okay, so this suggests that it could be a software problem. Are all three systems running the same version of OSX and dependencies? – Jester87 Apr 3 '13 at 16:13

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.