9

I'm trying to install a 10gen build of MongoDB on my local Mac running Mountain Lion (10.8.3):

I fetch it with curl at:

curl http://downloads.mongodb.org/osx/mongodb-osx-x86_64-2.4.tgz > mongodb.tgz

But I can't extract the build:

Attempt 1:

$ tar -zxvf mongodb.tgz

tar: Unrecognized archive format
tar: Error exit delayed from previous errors.

Attempt 2:

$ gunzip mongodb.tgz

gzip: mongodb.tgz: not in gzip format

Attempt 3:

$ unzip mongodb.tgz

Archive:  mongodb.tgz
  End-of-central-directory signature not found.  Either this file is not
  a zipfile, or it constitutes one disk of a multi-part archive.  In the
  latter case the central directory and zipfile comment will be found on
  the last disk(s) of this archive.
unzip:  cannot find zipfile directory in one of mongodb.tgz or
        mongodb.tgz.zip, and cannot find mongodb.tgz.ZIP, period.

Double Clicking: If I double click the tgz file in the finder, it creates a new file mongodb.tgz 2.cpgz


Any idea what I'm doing wrong here? I tried various builds and they all reproduce this issue:

http://downloads.mongodb.org/osx/mongodb-osx-x86_64-2.4.tgz > mongodb.tgz
http://downloads.mongodb.org/osx/mongodb-osx-x86_64-2.3.tgz > mongodb.tgz
http://downloads.mongodb.org/osx/mongodb-osx-x86_32-2.4.tgz > mongodb.tgz
http://downloads.mongodb.org/osx/mongodb-osx-x86_32-2.3.tgz > mongodb.tgz
1
  • 3
    do a "file mongodb.tgz" to identify the content type... – andrekeller Mar 19 '13 at 19:36
8

you are trying to gunzip/untar not the archive file but the error page:

<html>
<head><title>403 Forbidden</title></head>
<body>
<h1>403 Forbidden</h1>
<ul>
<li>Code: AccessDenied</li>
<li>Message: Access Denied</li>
</ul>
<hr/>
</body>
</html>

try this link http://fastdl.mongodb.org/osx/mongodb-osx-x86_64-2.4.0.tgz

1
  • I can't believe I didn't think to open that link in a browser. I'm reporting it to 10gen so they can fix the link. Cheers mate :) – AlienWebguy Mar 19 '13 at 20:23
2

Apologies, try http://fastdl.mongodb.org/osx/mongodb-osx-x86_64-2.4.0.tgz The download URL changed with the release which we'll fix in the docs.

7
  • What are you apologizing for? Why are you repeating the link that Alex already gave? – Scott Mar 19 '13 at 21:27
  • Because I own the docs website where this was in error? We recently changed to version the MongoDB documentation, as a sideeffect instead of including the release (2.4.0) we were including the version (2.4) in these URLs which are updated when we do a new release. – epc Mar 20 '13 at 17:45
  • 1
    (1) No error, but it might have been nice to (briefly) state your affiliation/association in your answer, rather than forcing us to open your user page. (2) Why are you repeating the link that Alex P. already gave in his answer, which he posted more than an hour before you posted yours? – Scott Mar 20 '13 at 18:09
  • @Scott. It is nice to get an official answer, where available. – TRiG Mar 15 '17 at 11:35
  • @TRiG: (1) Wow!  If you had just waited another four days, you could have observed the four-year anniversary of this answer.  Is this four-year-old information still valid/useful?  (2) Thanks, but I understood the significance of @epc’s comment that he is the owner of the MongoDB docs website; i.e., that his answer represented an “official” one.  (3) After four years, the answer still doesn’t include any claim to authority by association. – Scott Mar 16 '17 at 16:41

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.