I have trouble and headhakes with BIND9 on Debian6/64, made with Webmin. Basically I don't think Webmin is a problem, but I am just mentioning it. So, I made a DNS master zone with BIND and the domain registrar does not accept it, when trying to paste, for example ns1.domain.org and ns2.domain.org on registrars dns change page. I use the wooden language so anyone can understand, reading further. I hope it helps. The BIND server, is hosted at, as in example bellow, so the domain should point to it. This is an example of the zone. I replaced the actual domain with a generic :

    $ttl 38400
domain.org.       IN      SOA     domain.org. web.domain.org. (
                        38400 )
domain.org.           IN   A
domain.org.           IN   AAAA       2001:4b98:dc0:43:216:3eff:feef:c290
ns1.domain.org.      IN   A
ns2.domain.org.      IN   A
ns1.domain.org.      IN   AAAA       2001:4b98:dc0:43:216:3eff:feef:c290
ns2.domain.org.      IN   AAAA       2001:4b98:dc0:43:216:3eff:feef:c290
domain.org.           IN   NS         ns1.domain.org. 
domain.org.           IN   NS         ns2.domain.org.
www.domain.org.       IN   CNAME      domain.org.
mail.domain.org.      IN   MX  10     domain.org.  IN   PTR        mail.domain.org.
0.9.2.c.f.e.e.f.f.f.e. IN PTR mail.domain.org.  IN   PTR        domain.org.
0.9.2.c.f.e.e.f.f.f.e. IN PTR domain.org.  IN   PTR        ns1.domain.org.
0.9.2.c.f.e.e.f.f.f.e. IN PTR ns1.domain.org.  IN   PTR        ns2.domain.org.
0.9.2.c.f.e.e.f.f.f.e. IN PTR ns1.domain.org.

Why the DNS is not accepted ? Is a newly created zone. I did something wrong, or I need to wait for it to propagate, so it can be accepted ? The registrar says the entered DNS is not qualified and shifts back to it's default dns.


Its not possible to answer definitively on the information you provided, however from my experience [which is relevant I've set up more then 1 ISP and worked at a registrar as well ] -

I wonder if the problem is with GLUE records. You have specified ns servers which are a subdomain of the zone. In order to support this your registrar needs to know how to access the DNS servers without looking at the zone. This means you need glue records (basically you need to specify IP addresses for the NS records for your zone to the registrar). You may want to look into this closely and/or discuss with your registrar how they handle this - some registrars require it done manually.

Does your registrar support IPV6 registrations ? If not, that might be the problem.

Other observations:

  1. It is probably not a problem with BIND. I am unaware of any reason any registrar that requires a valid zone before they will accept the name servers - In fact I doubt they can check the zone is valid !!!

  2. I have not seen a setup with the reverse (ARPA) entries in the zone for another file and I'm pretty sure this is wrong. This should probably be a separate domain. I say probably because I've not yet dealt with IPV6 records, but I'm pretty sure I'm right.


Good point ! I was just looking around and found something that says somewhat the same. I have to make the same nameservers in registrar and put the ip there. I didn't quite knew those are called glue records. Here is the post I found, stating it : https://stackoverflow.com/questions/4308990/setting-up-a-custom-nameserver-with-bind9

Now I wonder, why do I need BIND if the registrar already has some domain (dns) handling side, where I can set them up ?! I tried to do that before, with another domain but for some reason did not worked, so I tried this BIND variant. Maybe I got something wrong but technically, by my calculations, it should work. I will try that again. Probably I have to wait for propagation.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy