14

I'm using word 2010 and I'm trying to create a TOC for a right-to-left language. The problem is that word creates the TOC as left-to-right, meaning that the chapter names are on the left side and the page numbers on the right.

Can it be changed?

thx

6 Answers 6

7

After you create the TOC in word:

  1. Select the text in the table, and right click on it.
  2. Choose Paragraph from the menu.
  3. In the General sector under the Indents and Spacing tab, choose Direction: Right-to-left.

This worked for me.

3
  • It's working, though leaving it in the same language - which is good only if you aren't trying to switch between a left-to-right language to right-to-left language in addition to changing the direction of the text.
    – Oz Edri
    Commented Nov 6, 2015 at 22:21
  • 1
    This didn't work for me. Well, it did but whenever I refresh the table it goes back to RTL
    – DAE
    Commented Dec 23, 2019 at 11:48
  • 2
    I found this question via Google. What worked for me is to open the Page Setup dialog (under Page Layout - Page Setup) and choose the Section Direction as Right to Left. This even reconstructs the ToC as roght to left even when I "Update the whole table" instead of just updating the page numbers.
    – asibahi
    Commented Jan 5, 2020 at 10:36
4
  1. Select the table of contents
  2. Navigate to Layout -> Page Setup -> Layout
  3. In Section -> Section Direction Select Right-to-left.

This worked for me on Microsoft 365.

enter image description here

I have done this multiple times and it works. This was suggested by asibahi in a comment to the answer by Mohmad El-Yamani but it was never in a answer, so credits go to asibahi.

When I tried the answer by Mohmad El-Yamani to choose Right-to-left in the Paragraph menu, it worked more or less OK, but there were some indentation problems and when I updated the table of contents, it changed back to Left-to-right and I had to change it again.

0

Try looking under the "File > Options > Language > Choose Editing Languages"

0

«Try looking under the "File > Options > Language > Choose Editing Languages"» (thanks to hinekyle answer) then create a new document and move your content into it.

0
  1. Select all the Content.
  2. Right Click.
  3. Paragraph.
  4. Set as Default.
  5. This Document only.

NOTE-It work if your default Microsoft Word install was in English. :)

-1

In addition to "hinekyle & Ebrahim Byagowi" answers,

just copy your contents to the new document by select all of content, DO NOT copy it with ctrl+A, otherwise it will copy the old TOC format as well.

"""Works with me on Word 2013""" ---> apparently this would works fine with a small size document's content.

And the nice part of that method, you do not need to change TOC direction to "Right-to-Left" each time when you update the entire table (as that is not one of MS Word default options).

1
  • Do those other answers not work for you?  If they don’t, say so (by asking a new question, linking to this one).  If they do, why give an answer suggests something clunky like copying the entire document contents into a new document?  (In real life, that’s more work than you make it seem.)  And what, exactly, do you mean by «select all with "shift" button,»? Commented Feb 16, 2017 at 22:41

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .