I recently added a new data drive to replace an old data drive. I proceeded to copy files from the old drive to the new drive, and then I swapped the drive letters so that the new data drive will have the same drive letter as the old drive. I do not have the old drive available to me anymore, only the new drive is connected.

Ever since then, I've noticed that I am unable to open a folder through explorer.exe in the command line. That is, if I run


it will launch a window perfectly fine. However if I run

explorer.exe c: 

it does not do anything. I see the process appear, but I do not see anything show up. The process seems to stay around for a bit, then closes.

I've tried searching across the web, but nothing seems to have been specific to this issue. I'm pretty sure it must have been me swapping the drive letter.

I've looked through the registry to see if there are any indication of any non-existant drive letter references, but I've only found information within VolumeInfoCache in Windows Search.

Resolved: (I will post an answer later due to inability to answer my question as a newbie).

I resolved the issue. Classic case of forgetting exactly what I did after swapping the drives.

In addition to swapping out the drives and assigning new drive letters. I also moved where some of the personal documentation libraries were pointed. Unfortunately, I didn't do it correctly for one of the folders (Personal folder, to be specific). It was still pointed at a path that no longer was valid.

I ended up using ProcMon to monitor the process and saw that explorer kept on failing to read something within the registry in ShellFolder. Looking through ShellFolder I saw that I missed one of the changes and changed it to the appropriate path. This seemed to have fixed the issue and explorer launches folders correctly now.

Thanks for your help Lee, Karan, and luchosrock.

  • If you disconnect both data drives, does Explorer work properly again on the OS drive? If so, try connecting each data drive in turn (i.e. power up and shut down each time) and see if the problem is resolved.
    – Karan
    Mar 21, 2013 at 17:06
  • @Karan I no longer have the old drive available to me (will edit question to reflect this) so I was only able to disconnect the new drive. After shut down and restart, explorer still does not work.
    – Sarai
    Mar 21, 2013 at 17:21
  • If you type the explorer C: from cmd, does it inform you something about the error?
    – luchosrock
    Mar 21, 2013 at 17:29
  • @luchosrock it simply spawns a new explorer.exe and then returns. No error or any indication that something has happened. I don't see anything in windows event viewer either (if it gets outputted there).
    – Sarai
    Mar 21, 2013 at 17:33

2 Answers 2


Try running diskpart and assigning a drive letter to the new drive.


Just make sure you select the proper disk. No real danger in doing this either.

  • Did not seem to have resolved the problem. I have two partitions on the new drive, so I did the following for each: select volume, assign letter to the same one as it had (D and E respectively), exit.
    – Sarai
    Mar 21, 2013 at 17:24
  • That is very strange indeed, diskpart is usually good about stuff such as this. Mar 21, 2013 at 17:32
  • I found the issue, updated my question (couldn't answer it since I'm new, so will do later). Thanks for the help.
    – Sarai
    Mar 21, 2013 at 18:02
  • Glad you got it fixed Mar 21, 2013 at 18:15

I had a similar problem as the original poster.

By mistake, I had dragged "My documents" to a different directory. Thinking I had copied it and not moved it, I deleted it.

Now, "Documents" collection pointed to a destination that did not exist.

I simply deleted "Documents" collection, since I do not use it anyway.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.