I have a nasty problem with Windows 7 and a CF card in a SATA card reader.

Hardware specifications:


  • Insert CF card into CF card reader
  • Insert Windows 7 SP1 32-bit DVD
  • Boot from DVD
  • After Windows DVD has copied install files and the animated Windows logo appears it hangs/gets stuck (the logo still animates), when this occurs the CF card readers LED turns off (being turned on when power is switched on).
  • If the CF card is removed when Windows "hangs", the setup boot process will continue as normal.
  • The CF card can then be found after windows has booted (e.g. using HotSwap!).
  • However, any boot with the CF card inserted will hang the boot process. This happens when "classpnp.sys" is logged when booting with bootlog on (i.e. no windows logo). Note this means Windows boot hangs after classpnp.sys has been loaded. Just before the logon screen should appear.

What has been tried without any solution:

  • Booting into safe mode does not help
  • Updating BIOS
  • Both IDE and AHCI SATA modes
  • Moving HDD and/or CF card reader to other SATA ports
  • Moving CF card reader to PCI express SATA card
  • Customer Support Module=Auto
  • Customer Support Module=Enabled using only "legacy opROM" under CSM (Customer Support Module) in Asus UEFI BIOS
  • Customer Support Module=Disabled
  • Changing SATA port with CF card reader to Hot Plug=Enabled
  • Secure Boot OS Type=Other OS
  • Using Windows 7 DVD without SP1
  • Tried removing CF card from boot order
  • Tried disabling legacy USB support

  • It seems that the boot does not hang forever, but actually boots after a very long time. Hours as far as I can tell. Once booted, most things work, except the CF card does not show and running "Disk Management" just displays "Connecting to Virtual Disk Service...", for about 10 minutes until the CF card shows up.

  • Clarified hang occurs after classpnp.sys has been loaded. Also tried installing latest Intel Chipset Driver No change.

  • Tried some boot order stuff combined with hot plug enabled, no luck yet.

  • Note this problem exists on 3 identical PCs with the Asus P8C WS board, but does not exist if using a different motherboard + CPU, but otherwise the exact same hardware. Thus, everything points to an issue with the Asus P8C WS board/Intel C216 chipset.

  • No matter what, as long as the Compact Flash card is inserted into the card reader during boot and no other hardware except DVD drive (from which Windows 7 install is booted) the problem persists. I also tried different CF cards.

  • I have read a couple of places that this might be a SATA/mass storage controller issue e.g. chipset issue, so I have also tried putting the card reader on a separate PCI express - SATA controller (ASRock SATA3 CARD/ASR). However, this did not resolve the issue either.

There are a lot of similar questions on superuser and elsewhere, but none appear to resolve this issue, as far as I can tell. Below I have listed possible questions that might be considered duplicates but are not pertinent to this case or do not indicate proper solution:

  • I've faced similar issues before (had a tough time with a friend's laptop before we finally figured out there was a forgotten SD card inside the in-built card reader). For this reason I always carefully check that no USB sticks, memory cards etc. are present before installing Windows. I recommend you do that same instead of trying to figure out what went wrong during the installation process and where Windows might have mixed up drive IDs and so on. – Karan Mar 21 '13 at 17:10
  • 1
    Do you need the card during installation? Can't you just remove it and put it back after the install has finished? – terdon Mar 21 '13 at 17:10
  • I do not need the card during installation, but as I said the problem is the same after installation i.e. when Windows has been installed and it boots the problem persists. And we really need to be able to let the CF card stay in the PC during normal usage ;) – nietras Mar 22 '13 at 8:21
  • I have had some suggestions from CF card reader suppliers, that this might be a mass storage controller driver issue. However, I have no idea how to fix this, since I tried updating the chipset driver, and since the builtin class driver in Windows 7 should work. – nietras Mar 22 '13 at 17:19
  • Have you ever tried toggling the EHCI Hand-off? – Der Hochstapler Mar 26 '13 at 14:46

The CF card is being seen in the BIOS as a boot device. See if there is an option in the bios to disable external device boot, or perhaps it may be in the boot order.

|improve this answer|||||
  • This would make sense, but even if disabling this from boot order priority list, it does not help. I cannot find other options to disable this as a boot device, as such. Note this test was done with just DVD drive and the CF card attached, then booting from Windows install DVD. It hangs after loading files, just showing the "Starting Windows" logo ... pulsing. Thanks for the suggestion though. – nietras Mar 22 '13 at 11:16
  • This got me thinking, is it possible to get a SATA-CF card reader which does NOT support booting from it? While still reading the cards serial number? (USB does not work) – nietras Mar 22 '13 at 11:25
  • Is there any way to verify that the CF card is seen as a boot device? It might be a BIOS bug that does not allow this to be disabled or something. – nietras Mar 22 '13 at 11:36
  • @harryuser I don't see how it can be a BIOS problem, what you describe happens well after the BIOS has given over control to the OS doesn't it? – terdon Mar 22 '13 at 12:08

Classpnp.sys problems usually (but not always) point to disk problems. It is possible that the problem arises because the BIOS wrongly sees the card reader as an external (or internal?) hard disk.

I have had exactly the same problem, but with a USB3-capable external disk branched on a USB2 port.

When the disk was branched on the USB2 port, the laptop hung during boot inside the BIOS. However, if the USB3 disk was withdrawn, then the BIOS finished its boot very quickly and Windows 7 then had no further problem, treating the USB3 disk when it was branched as USB2.

I have worked out an explanation for this behavior that I can share here, but I have no proof of it (nor any idea on how to get such a proof).

My idea is that the BIOS simply did not recognize the USB3 disk as one that it cannot handle. It badly analyzed the disk as being some other hardware, so it sent the USB3 hardware commands that it probably couldn't execute, then was waiting for an answer that never came. There may be a timeout for this wait (or waits), but you have found out that it may take hours to elapse.

On the other hand, when Windows took control, it correctly analyzed the USB3 disk and used for it a USB2 driver which worked correctly.

If that explanation applies to your case, then the CF card reader confuses the BIOS, but is correctly being analyzed by Windows. Therefore, if you cannot find a BIOS version for your computer that can handle this card reader, then you should never boot with a card inside it. The BIOS probably misreports the card as some other hardware.

|improve this answer|||||

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.