I have three external HDDs in a USB enclosure. After a recent upgrade to Windows 7, during which these three drives were actually installed inside the PC tower, two of the three drives now have a 200 MB EFI partition, and the two drives do not show up as usable drives under either Windows 7 or Snow Leopard. One of the drives is empty; the other one, however, has a bunch of stuff on it that I want to save if possible.

How can I get back to this data? Can I simply delete the EFI partition, and all will be well? Or do I have to do something trickier? Or am I just hosed?

5 Answers 5


I am assuming that you originally formatted these drives on an Intel Mac (OS X) system.

Rather than paraphrasing what I've heard in other places I'll simply quote from the Wikipedia article for EFI System partition.

On Apple–Intel architecture Macintosh computers, the EFI partition is initially blank and not used for booting.

However, the EFI partition is used as a staging area for firmware updates; specifically it places a firmware flash utility (EFI binary) and data file (FD – "Firmware Device") in the directory EFI/APPLE/FIRMWARE which is then run when rebooting the system in "flash firmware" mode.

If deleted, the system will still boot, and the boot manager will still allow users to choose whether to start a Boot Camp partition or the default Mac OS X, but firmware updates will fail.

As I believe has been pointed out in other answers, the EFI partition is not used by Windows 7 and is not created when using a system which does not use EFI. In other words, if you are not going to use these drives as anything other than data drives then, yes, you can delete the EFI partition.

I'm afraid I did not take the time to experiment and find out if deleting the EFI partition will resolve the problems you are having with Windows 7 "seeing" your NTFS partitions on the drive. But it seems like it would be worth trying.

If I recall correctly you will not be able to delete the EFI partition from the Windows Disk Management utility. One way you could delete the EFI partition(s) is by running DISKPART from a (elevated) Window's command prompt.

I do this by first selecting the partition I want to delete and then verifying that I've selected the correct partition. Below is an example with one of my drives.

After you are sure you have selected the partition you want to delete, the command
delete part override
should delete it.

(If you don't care about any of the data on the drive and just want to repartition it, you could also use the clean command. For more info about it, type HELP CLEAN in DISKPART.)

Hope this helps.

DISKPART> list disk
  Disk ###  Status         Size     Free     Dyn  Gpt
  --------  -------------  -------  -------  ---  ---
  Disk 0    Online           76 GB      0 B
  Disk 1    Online          372 GB    32 GB
  Disk 2    Online          465 GB      0 B
  Disk 3    Online          931 GB      0 B
  Disk 4    Online          149 GB   255 MB        *

DISKPART> select disk 4
Disk 4 is now the selected disk.

DISKPART> list part
  Partition ###  Type              Size     Offset
  -------------  ----------------  -------  -------
  Partition 1    System             200 MB    20 KB
  Partition 2    Unknown             37 GB   200 MB
  Partition 3    Unknown            111 GB    37 GB

DISKPART> select part 1
Partition 1 is now the selected partition.

DISKPART> detail part
Partition 1
Type    : c12a7328-f81f-11d2-ba4b-00a0c93ec93b
Hidden  : Yes
Required: No
Attrib  : 0000000000000000
Offset in Bytes: 20480

  Volume ###  Ltr  Label        Fs     Type        Size     Status     Info
  ----------  ---  -----------  -----  ----------  -------  ---------  --------
* Volume 15        EFI          FAT32  Partition    200 MB  Healthy    Hidden
  • Thank you so much for clearing this up. I have a Win7/OSX dual boot setup (MBR) where the EFI belongs to Windows. (I did not have your info when I created the setup.) Windows now requires the EFI, and OSX requires it only for firmware updates. To upgrade to Mavericks (requires firmware update), I intend to temporarily swap out the hard drive. After upgrading the firmware using an empty hard drive, I wish to swap the original back in and update the software to Mavericks to complete the process. Any ideas, warnings or alternatives?
    – Timo
    Feb 10, 2014 at 12:36
  • @Timo It is still my understanding that for a dual-boot (Boot Camp) OS X/Windows 7 system, which uses a hybrid kludge of MBR/GPT partitioning, Windows would NOT require the EFI partition. Why do you say that "Windows now requires the EFI"? Feb 10, 2014 at 16:25
  • @irrationalJohn When I delete the EFI, Windows fails to boot. In prior setups, I had Windows installed through Boot Camp assistant, in which case in does not create nor require an EFI. But using this 'plain' install, Windows cannot live without it. I wonder if I can change this in the current situation?
    – Timo
    Feb 25, 2014 at 14:52

I just had a similar problem and delete part or delete volume were actually crashing diskpart!

On another forum I found the command "clean" which cleans the currently selected disk.

> list disk
> select disk 1
> clean

and now the disk is VERY clean. It does not have an MBR or GPT. In my case I wanted to install Server 2008 (not R2) and so I had to remove the GPT from a disk which had previously run Windows 7


I faced a problem with my Iomega iConnect "seeing" one of the NTFS partitions on my external HDD.

I had to delete the EFI partition on the drive (it used to be my MBP internal drive before I replaced it) and then everything worked fine.

If you are having problems with Windows 7 reading the NTFS drive, this could be a possible solution.


A 200 MB partition is nothing significant by today's standard. If I were you, I wouldn't mess with it.

But, I have had an experience regarding deleting an EFI partition. I tried to delete the EFI in a Mac OS X partition. It turns out Mac OS X will not be able to read the NTFS partitions existing in the EFI harddisk. I got it fixed when I reformatted the whole harddisk to use a GUID Partition Table (GPT).

Also, I doubt there is any significant data in the EFI partition, but anyway here is how you mount it in Mac OS X:

mkdir /Volumes/EFI
mount_hfs /dev/disk0s1 /Volumes/EFI
  • I'm not worried about the 200MB of space; that's peanuts when we're talking about nearly 6TB of disks. My problem is, these little partitions suddenly appeared (or maybe they've been there all along and I just realized it), and now I can't access the other 9.5GB of data on one of the drives.
    – Andy
    Oct 20, 2009 at 12:06
  • Have you try to look for that 9.5GB of data in Windows 7?
    – deddebme
    Oct 20, 2009 at 15:14

Did you try plugging the drive with the inaccessible data into the Windows 7 PC internally after discovering your issue?

I don't think it's likely that you could have somehow created an EFI partition on a drive without issuing a command to do so. Either those partitions were there before your upgrade, or you told the installer for Windows 7 to do something to create them. Check out the article Installing Windows to an EFI-Based Computer regarding systems that support both EFI and BIOS:

If Windows Setup starts in BIOS mode on a combined EFI/BIOS system, the ESP and MSR partitions are not created. After Windows Setup completes, use the Diskpart command to verify that the ESP and MSR partitions were created.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.