I have a problem similar to the one described in the question:

Windows is very slow with my new SSD

I believe what I need is to install the proper driver for either the SSD or the motherboard, but I don't really understand what I need.

I have found that one guy resolved same thing by installing driver for "Intel 5 series 4 port SATA AHCI controller" (http://forum.crucial.com/t5/Solid-State-Drives-SSD/SOLVED-Crucial-v4-CT256V4SSD2-disastrous-performance/td-p/110668).

I've tried to do the same, but can't find appropriate driver on the Intel Download portal. I've tried to find "SATA AHCI Controller windows 8" on http://downloadcenter.intel.com/SearchResult.aspx?lang=eng, but it gives only RAID drivers.

Am I correct and I need to install a driver of some kind? If yes, what driver(s) do I really need?

Probably need to update BIOS? That sounds dangerous. Do I really need to do that?

More details about my problem:

I recently bought SSD drive (V4-CT256V4SSD2) and moved to Windows 8.

HDTune confirmed the max speed of the new drive is 250Mb/s. For me that sounds like the system recognized and uses drivers for the SSD.

Though, I've noticed quite a few strange things:

The 1st strange thing is observed during big files copying from HDD. Data transfer speed was very low. I copied big files from HDD to SSD (100-1000MB each) with Total Commander and it showed average speed changing from 5 MByte/sec to 50 MByte/sec. Task Manager on the "Performance" tab displayed that drive C: (actual SSD drive where I copied files to) was 100% busy, write speed was also varying from 5MB/sec to 50MB/sec. Average response time was around 800 - 1500 ms.

I understand the top limit (limited by HDD read speed), but can't understand why sometimes copying speed dropped to such a low level.

Another problem is with applications installations. Right now I'm installing MS Office and have a pretty similar situation: Drive C: is 100% busy, but write speed is 200 KB/s - 1000 KB/s, average response time - 400 - 1500 ms...

For me that looks like disk write operations are overseen by Windows Defender (I have default configuration) and it validates all requests and verifies they don't have any 'viruses'. But I stopped defender (turned off real time protection) to check if something would change and that had no visible impact on file transfer speed.

Please let me know if any additional information is required to understand the problem.

Thanks a lot in advance!

P.S. I have motherboard based on P35 chipset (it is quite old, but still performs well for me).

  • which chipset do you have? Only the ICH9R officially support AHCI. If you use the ICH9, you run in IDE mode and this would explain the slowness. There are driver .inf hacks to enable AHCI but I've never tried this. Mar 24, 2013 at 6:20
  • I believe I have ICH7 (as I quite often see that world in the "device manager"). Carl, could you please advise what should I search for? From your comment i believe i need to find the ".inf driver hacks that enable AHCI"? Should I add some other keywords for my search? Thanks!
    – Budda
    Mar 30, 2013 at 20:21
  • if you use the ICH7 you don't get AHCI. Here is the trick, but I don't know if this works: neowin.net/forum/topic/457699-enable-ahci-on-intel-chipsets Mar 30, 2013 at 20:28

2 Answers 2


I've get expected performance...

What didn't work:

  • getting drivers - they are just not released for my MB
  • purchasing new Mother Board (memory, CPU, Video) - it become 10-15% better, not much more. In fact, my system become quicker but still had issues with performance.

What did work:

is firmware update. It was released around 2 months ago, and roughly in 1 month after I posted the question.

Visually system become much more responsive; Overall performance increased from this: enter image description here

to this:

enter image description here

More details about my journey are on official support forum of Crucial: http://forums.crucial.com/t5/Solid-State-Drives-SSD/Crucial-V4-SSD-S5FAMM25-Firmware-available/m-p/127434/highlight/false#M36988, page 12, message #107 (at ‎06-04-2013 01:34 AM)


Update to previous answer: update of firmware helped for a while, but problem become more severe again.

Eventually I called to Crucial support and asked for compensation of reasonable price of SSD, they did... and eventually I got SSD performing as quick as SSD should.

Some details are in topic:

http://forums.crucial.com/t5/Solid-State-Drives-SSD/Crucial-V4-SSD-S5FAMM25-Firmware-available/m-p/129916#M37582, message #112

But in fact, I also posted there information they gave me a credit, though looks like that my message was deleted by admins.

  • You should just update your original answer.
    – Ramhound
    Apr 26, 2014 at 4:13
  • 1
    That's 2 different approaches, that's why i choose another post. You can keep downgrading people for posting USEFUL comments. That's your choice
    – Budda
    Apr 27, 2014 at 19:45

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .