I have Winodws 7 on my computer and I am trying to install Linux Mint 14 on the same computer. The hard drive has four primary partitions and thus it is impossible to boot Mint from it since I cannot add a new partition and I don't want to modify the old ones. But I have an external hard drive connected to that computer and I am installing Mint on it. So this is how it looks like after I am done with partitioning:

sda1 ntfs
sda2 ntfs
sda3 ntfs
sda4 ntfs

sdb1 ntfs
sdb2 ntfs
sdb5 swap
sdb6 ext4

So obviously I am installing Mint on sdb6 with mount point / and device for boot loader installation /dev/sdb6.

Then from Windows 7 I start EasyBCD and add a new Linux entry with GRUB boot loader and choose partition 4 from the second disk. On boot the only thing I see when choosing the Linux option is a blank cursor that blinks forever. Starting from the live USB I can see that GRUB is indeed installed on the Mint partition. This is the contents of the /boot directory:

boot $ ls -l
total 24052
-rw-r--r-- 1 root root   844882 Oct  9 19:54 abi-3.5.0-17-generic
-rw-r--r-- 1 root root   147884 Oct  9 19:54 config-3.5.0-17-generic
drwxr-xr-x 5 root root     4096 Mar 23 18:40 grub
-rw-r--r-- 1 root root 15228745 Mar 23 18:40 initrd.img-3.5.0-17-generic
-rw-r--r-- 1 root root   176764 Oct 11 14:10 memtest86+.bin
-rw-r--r-- 1 root root   178944 Oct 11 14:10 memtest86+_multiboot.bin
-rw------- 1 root root  2901710 Oct  9 19:54 System.map-3.5.0-17-generic
-rw-r--r-- 1 root root  5129040 Nov 27 16:56 vmlinuz-3.5.0-17-generic

This is the contents of grub:

boot/grub $ ls -l
total 160
drwxr-xr-x 2 root root   4096 Mar 23 18:39 fonts
-r--r--r-- 1 root root   6479 Mar 23 18:40 grub.cfg
-rw-r--r-- 1 root root 128000 Mar 23 18:39 grub.efi
-rw-r--r-- 1 root root   1024 Mar 23 18:39 grubenv
drwxr-xr-x 2 root root   4096 Mar 23 18:39 locale
drwxr-xr-x 2 root root  12288 Mar 23 18:39 x86_64-efi

I've done the same trick before with Ubuntu on other computers, though installing it on the built-in hard drive and it has always worked. What could be wrong this time?


I converted one of the primary partitions on the built-in hard disk into logical and installed Mint on the free space. And it still doesn't work.


I tried to reinstall GRUB from a live USB but it still doesn't work. This are the steps that I took:

int@mint ~ $ sudo mount /dev/sdb6 /mnt
mint@mint ~ $ sudo mount --bind /dev /mnt/dev && sudo mount --bind /dev/pts /mnt/dev/pts && sudo mount --bind /proc /mnt/proc && sudo mount --bind /sys /mnt/sys
mint@mint ~ $ sudo chroot /mnt
mint / # grub-install --force /dev/sdb6
Installation finished. No error reported.
mint / # grub-install /dev/sdb6
Installation finished. No error reported.
mint / # grub-install --recheck /dev/sdb6
Installation finished. No error reported.
mint / # update-grub
Generating grub.cfg ...
Found linux image: /boot/vmlinuz-3.5.0-17-generic
Found initrd image: /boot/initrd.img-3.5.0-17-generic
Found Windows 7 (loader) on /dev/sda1
Found Windows Recovery Environment (loader) on /dev/sda2
Found Windows 7 (loader) on /dev/sda3
mint / # exit && sudo umount /mnt/dev && sudo umount /mnt/dev/pts && sudo umount /mnt/proc && sudo umount /mnt/sys && sudo umount /mnt

2 Answers 2


the problem may be with grub. Try booting with the help of super grub2. If you successfully got ur mint booted then the problem is with incorrect grub entry

  • How do I boot with GRUB2? Do you mean that I should select it instead of GRUB in EasyBCD? I already tried that and it didn't work. I also tried booting with EasyBCD's own GRUB and auto detection of the Mint partition but it didn't work either. Mar 23, 2013 at 20:01
  • download a software named Super grub2 and see.
    – Shankar
    Mar 27, 2013 at 12:07

I guess GRUB is installed in sdb's MBR. This is default for Ubuntu and GRUB will protest when trying to install it to a partition's bootsector manually, so it would be reasonable if they left it like that in Mint. So boot from sdb, not sdb6.

You can also install GRUB4DOS, NeoGrub or Grub2Win and chainload that GRUB from it or boot directly to Mint (the latter may be tricky).

If none of these work, reinstall GRUB to sdb6 (you'll have to use --force).

  • I tried booting from sdb. I even reinstalled Mint setting the boot loader explicitly on sdb (not sdb6 as before) and it doesn't work. Even if I switch the HDD priorities - still nothing. Mar 23, 2013 at 23:53

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.