I'm running Adobe AIR 1.5.2 (latest) on Windows 7 (64-bit RTM) and downloaded TweetDeck 0.31.1 (latest). When I run TweetDeck I get the following errors:

Ooops, TweetDeck can't find your data

enter image description here


Sorry, Adobe AIR has a problem running on this computer

enter image description here

Other AIR applications install and run fine. I've uninstalled both TweetDeck and AIR and reinstalled. Following the uninstalls I've also removed all on-disk references to both TweetDeck and AIR, but no luck.

UPDATE: Using Process Monitor I did a trace of Tweetdeck from the moment it launched until the first error occurred. I saw the following information in the output of the trace:

1 5:22:18.6522338 PM TweetDeck.exe 5580 
D:\ProgramData\Microsoft\Windows\Start Menu\Programs\rs\??\d:\Use\myusername\AppData\Roaming\Adobe\AIR\ELS\TweetDeckFast.F9107117265DB7542C1A806C8DB837742CE14C21.1\PrivateEncryptedDatak
Desired Access: Generic Write, Read Attributes, Disposition: OverwriteIf, 
Options: Synchronous IO Non-Alert, Non-Directory File, 
Attributes: N, 
ShareMode: Read, Write, 
AllocationSize: 0

In this trace output, Tweetdeck.exe is trying to create the file

D:\ProgramData\Microsoft\Windows\Start Menu\Programs\rs\??\d:\Use\myusername\AppData\Roaming\Adobe\AIR\ELS\TweetDeckFast.F9107117265DB7542C1A806C8DB837742CE14C21.1\PrivateEncryptedDatak

but the path specified is invalid. When looking at the path you can see that it is indeed an invalid path. First, there’s the “??” portion which doesn’t exist in the file system since the “?” is an invalid character in Windows/NTFS file systems. Additionally, looking at this path, it actually seems to be composed of two parts (is the "??" a delimiter?):

Part 1: D:\ProgramData\Microsoft\Windows\Start Menu\Programs\rs\??
Part 2: d:\Use\myusername\AppData\Roaming\Adobe\AIR\ELS \TweetDeckFast.F9107117265DB7542C1A806C8DB837742CE14C21.1\PrivateEncryptedDatak

(the problem here is that d:\Use... doesn’t even exist.

What seems to be happening here is that Tweetdeck is looking for the user credentials (the “PrivateEncryptedDatak” file) but it’s looking in the wrong place, can’t find the file, and hence the error that Tweetdeck is giving (shown in the screenshot).

I'm trying to determine how TweetDeck is getting this path. I searched the contents of all files on my hard disk hoping to find some TweetDeck or Adobe AIR configuration file containing this incorrect path, but I was unable to find anything.

UPDATE: See Carl's comment regarding directory junctions and symbolic links under my accepted answer. This ended up being the problem.

Edit by Gnoupi: People, the answer section is there to provide an actual ANSWER, not to say you have the same issue. It doesn't help anyone that you have the same problem. Eventually, if you think this is really worth mentioning, put it as a comment under the question.

But simply, if what you want to add is not an answer to the question, then don't post it as an answer. This is not a forum, I recommend new users to read the FAQ: https://superuser.com/faq

  • 1
    I like the way the error message says what clicking "Submit" will do, when there's no "Submit" button.
    – CarlF
    Commented Nov 14, 2009 at 3:10
  • +1 for the text accompanying the screen captures. I like SEO-friendly questions!
    – Arjan
    Commented Nov 18, 2009 at 23:30

4 Answers 4


I'm very concerned about the problem you've experienced and described. Although I'm not able to reproduce it, I'm nonetheless trying to make things work better. In order to narrow down the number of hypotheses and fixes I'm considering, it would help tremendously if you could post the actual values of the two environment variables Lawrence mentioned. Would you please, please provide the values of APPDATA and USERPROFILE from the Vista machine exhibiting the problem, even if those values appear to be as expected. It is fine to substitute "myusername" for your user name ;^). I'm asking for those values because of the MSDN documentation for APIs being used. You can see the details if you look for "Roaming" in:


  • Hi Carl thanks for your interest. Here's the values: APPDATA=c:\Users\mkrieger\AppData\Roaming USERPROFILE=c:\Users\mkrieger Do you happen to be with TweetDeck or Adobe?
    – Matthew
    Commented Nov 17, 2009 at 17:00
  • Hi Matt, From the path values containing '\??\', it looks like directory links may be involved. If you are using links would you please verify that you are using Windows directory "junctions" rather than symbolic links? There is a bug resolving symbolic links that will be fixed in a future release of AIR.
    – Carl
    Commented Dec 5, 2009 at 0:22
  • Hi Carl I was indeed using symbolic links. I switched to junctions as you suggested and things worked as expected! Thanks...
    – Matthew
    Commented Dec 21, 2009 at 5:37

I had this issue with Ubuntu 9.10. For me it was caused because I didn't have some necessary 32-bit files installed (specifically, libgnome-keyring).

Following the instructions on Install Adobe AIR Linux 1.5 on 64-bit Linux distributions solved it for me.

Obviously this is a Linux specific answer, but it may cast more light onto the situation in order to help solve it for those on Windows too.


The path of the file creation is very strange: "D:\ProgramData\Microsoft\Windows\Start Menu\Programs\rs\??\d:\Use\myusername\AppData\Roaming\Adobe\AIR\ELS\TweetDeckFast.F9107117265DB7542C1A806C8DB837742CE14C21.1\PrivateEncryptedDatak" because of two characteristics: (1) d:\Use\ is using lower case drive, obviously not the system's default usage, (2) \Use\ is not a default usage for \User\, note the prefix "\rs\" can append to the tail "User" to construct back to a good value "User".

So I'm wondering some environment variables on your Vista machine have been changed to trigger the file access failure. Could you check your environment variables like APPDATA or USERPROFILE to see if they are well-formed? APPDATA should be like D:\Users\myusername\AppData\Roaming and USERPROFILE should be like D:\Users\myusername

  • hi Lawrence - this was one of the initial things I checked - I grepped SET output as well as did a complete registry substring search, and did a complete (and incredibly time consuming) file system search for the contents of ALL files in order to find the culprit. No dice. It may be encrypted and/or encoded in some Tweetdeck and/or AIR file. The path is indeed odd - it almost looks to me like two paths concatenated...
    – Matthew
    Commented Nov 14, 2009 at 23:21

I'm running SUSE 11.2 and the Adobe AIR beta. I've solved this issue deleting the folder .appdata/Adobe/AIR/ from my home directory.

This command should do the trick:

rm -Rf ~/.appdata/Adobe/AIR/

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .