25

I'm not sure how, but I managed to get Sublime Text into a 'Replace Mode' which at whatever position the cursor is at, it overwrites the next character with whatever you press instead of inserting it.

How do return back to 'Insert' mode?

I couldn't see any option for it in the menu and searching on Google yielded completely irrelevant results.

For the record, I'm using OS X Mountain Lion, and I have the non-extended keyboard (without the number pad).

1
  • Interesting, it only appears to be for that one document I was working on. Problem solved, but it would be useful to know how to enable and disable it.
    – Adam-E
    Mar 25, 2013 at 16:58

5 Answers 5

34

If you go to Preferences->Key Bindings (Default) and search for "overwrite" you'll find the key binding. At least on Windows it's set to the Insert key. You probably managed to hit some key combo to emulate that key on your keyboard. If it happens again and you can't figure out how to get out, just change it to CtrlAltShiftI (unused in my default setup) and you should be good to go. Make sure that you put this entire line in your Preferences->Key Bindings (User) file, in between the square brackets:

{ "keys": ["ctrl+alt+shift+i"], "command": "toggle_overwrite" },

The , at the end is only needed if you have additional entries in the file.

4
  • 8
    Great. In my defaults this was super+alt+o which I believe translates to ctrl+alt+o on Windows.
    – Adam-E
    Mar 28, 2013 at 16:15
  • 2
    @Adam-E - super is actually the Command key in OSX. I use Sublime both on Win and Mac, and sometimes super is changed to ctrl on Windows, and sometimes it isn't, which is a little frustrating. Luckily, most of my real work is on my Mac, which I love :)
    – MattDMo
    Mar 28, 2013 at 16:19
  • Works in Sublime Text 3. Dec 13, 2014 at 12:54
  • this was driving me crazy hehehe thank you!! Mar 24, 2017 at 14:47
19
{ "keys": ["super+alt+o"], "command": "toggle_overwrite" }

This setting is present in Preferences -> Keybindings - Default

i.e. on Mac Command+Alt+O

4

On a Mac, fn + return works as insert.

0
1

On the top row of a QWERTY keyboard there is a button marked INSERT. Simply tap that button. It toggles between Insert mode and Overwrite mode.

1
  • However, on a non-extended keyboard, there is no insert key.
    – Adam-E
    Jun 9, 2016 at 8:26
0

That unsettling key seems to be the "0" in the number pad, on the right. Just press it again and you will shift back to insert mode (at least that's how it goes in my linux laptop)

1
  • 1
    Your answer could be improved with additional supporting information. Please edit to add further details, such as citations or documentation, so that others can confirm that your answer is correct. You can find more information on how to write good answers in the help center.
    – Community Bot
    Jan 3, 2023 at 17:05

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .