We have an intermittent problem on Windows 8 whereby Ping fails to find the host but NSLookup resolves it correctly.

  • Ping host1 - fails with ping could not find host
  • Ping host1.domain.local - also fails with ping could not find host
  • IPConfig /displayDNS - lists host1 as Name does not exist
  • NSLookup host1 - works fine and resolves router correctly.

Have now done a network trace on this and seemingly found the following:

  1. The first ping request for host1 does not look to DNS for resolution but NbtNs, this fails and writes that failure to DNS cache.
  2. Second ping request for host1.domain.local does actually look to DNS for resolution but looks to secondary DNS server rather than Primary DNS server! This fails because secondary DNS server is on the
    external network, external to the domain.
  3. Any subsequent ping requests to either host1 or host1.domain.local fail because they are answered by the DNS cache with the previous failures.

Does any of this make sense, moreover what can I do to correct this weird behaviour and get Win 8 networking stack functioning properly?

I have read about this intermittent problem in various other threads but still no one seems to have a long term solution.

  • 1
    What happens if you try to ping in the other direction? If it works one way but not the other, the remote host might be configured to drop pings.
    – David
    Mar 25, 2013 at 21:41
  • Ping by IP number works fine, always. Just name resolution that goes wrong sometimes.
    – NickC
    Mar 26, 2013 at 10:12
  • Further info: Ping DNS server - ok but returns IPv6 address, not IPv4 <- could this be the cause of the problem
    – NickC
    Mar 26, 2013 at 11:58
  • I'm not really familiar with IPv6, so maybe? Check if IPv6 is enabled on both computer's? Can you ping both ways by IPv6 address?
    – David
    Mar 26, 2013 at 14:21
  • Ping Workstation -4 (from server) - ok, Ping Workstation -6 (from server) - fails, Ping Server -4 (from workstation) - ok, Ping Server -6 (from workstation) - fails
    – NickC
    Mar 26, 2013 at 15:43

2 Answers 2


Think I got it. Was having the same problem. Turned off IPV6 (disabled protocol in network adapter properties, i.e. unchecked box), and now it works.

By the way, I had to turn off IPV6 on the DNS server too.


Turn off DNSCache service seems to solve the problem. This suggests to me serious bugs in Win 8 DNSCache service. Unless there is some other explanation for what is causing the DNS Cache to get corrupted in the first place.

  • 1
    Just curious, did you try flushing and resetting the client resolver cache using ipconfig /flushdns before you turned off DNSCache service?
    – gm2
    Mar 30, 2013 at 17:50
  • Yes IPConfig /flushDNS usually cleared the problem. I say usually because just occasionally even that didn't work either.
    – NickC
    Mar 31, 2013 at 11:38

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .