1

I followed the instructions from previous posts on superuser to try and install cygwin including xorg-server as well as trying the alternative of bringing up X windows using Xming (including setting up the fonts), but I can't get any X windows to show up from my cygwin console:

$ xeyes
Error: Can't open display:

I tried with emacs, but only opens as emacs -nw would do.

Even though I installed xorg-server (and everything else under the xorg-* section), I don't seem to have startxwin installed:

$ startxwin
-bash: startxwin: command not found

Any ideas? Could it be related to security issues like an antivirus software or something?

2

Maybe you need to set your DISPLAY variable to tell Xorg where to display, try:

$ DISPLAY=:0.0 xeyes

:0.0 is the default display of Xming, you may need to change it accourding to your Xming parameters

1

Install the xinit package in cygwin to get startxwin.

  • I did but still doesn't let me have any X windows... – 719016 Apr 3 '13 at 9:13
  • Same here while using the experimental cygwin packages. Using the stable ones works for me. – Andrew Smart Jun 15 '13 at 18:50

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.