0

When I press ESC in VIm insert mode, instead of going back to control mode, my iTerm minimizes and does not go back to control mode, but it stucks in insert mode.

I am using Vim 7.3 that came with OSX Lion and iTerm2 Build 1.0.0.20130302

Any ideas?

EDIT: I also noticed that this is not just a VIm problem but an iTerm2 problem, since it toggles iTerm2 everytime i press ESC no matter in which program I am.

  • 2
    Well, this is obviously an iTerm problem. A quick look at the preferences, possibly the "Keys" panel, should solve your issue. – romainl Mar 26 '13 at 21:20
  • @romainl is there a way to reset iterm settings? thanks – intelis Mar 26 '13 at 21:20
3

Go to Preferences -> Keys and see if you have set up Esc as a system-wide hotkey for hiding and showing iTerm.

0

Most terminals will send the Escape code when you press Ctrl+[, so you can use that as a workaround if you'd like to keep the Esc key mapping.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.