I've been having some problems with my laptop recently. At first it started running slower until it started to just completely shut down without any error or warning. So, I started using diagnosis tools to try and find the problem. When I tested my RAM using Memtest86, I got this error:


Is it a serious problem? What should I do?

  • Although there is a good chance this is a memory problem as other answers state, its also possible the CPU is overheating and causing the problems. See superuser.com/questions/775/how-do-i-clean-dust-from-a-computer. Mar 27, 2013 at 1:38
  • @WayneJohnston: That can certainly cause the computer to shut down, but it shouldn't cause the RAM to fail the memtest.
    – Dennis
    Mar 27, 2013 at 1:39
  • @Dennis: I agree. Still, I don't understand how a memory problem would cause the computer to slow down. Maybe that's just a coincidence though. The shut down is certainly consistent with a memory problem. Mar 27, 2013 at 1:44
  • @WayneJohnston: We may have interpreted the question differently. If the computer has been running slow for an extended period of time, there are probably two unrelated issues.
    – Dennis
    Mar 27, 2013 at 3:14

4 Answers 4


The error Memtest86+ shows signals that a bit was flipped by the memory when testing it, i.e., Memtest86+ set it to 1 and it was 0 when it read the value (or vice versa).

Problems with RAM are always serious, since flipping a bit in memory can cause pretty much everything to happen. The normal outcome is system instability, but with a little bad luck, you could also store a system critical file (or any other file that is important to you) in this part of the memory, modify it and overwrite the original file.

If you're overclocking the RAM, stop doing that. Take the modules out of the slots and re-seat them to be sure they're not loose. Run the test again and, if it fails once more, replace the defective RAM module.


First, try re-running to make sure it consistently fails (it probably will, given enough time). Then replace the memory modules (hopefully they are a removeable part on your laptop).

  • I ran the test a few times, the red line appears each time after a few seconds from when the test starts. So, basically there's no fixing it, that module needs replacing? Mar 27, 2013 at 1:37
  • 2
    Replacing the RAM might be premature. As said above, reseat it. If it still fails, swap the sticks around if you have more than one stick. Do 1 stick at a time in different slots if your motherboard allows to verify it is the RAM and not a motherboard issue writing or reading from a specific channel or slot. Mar 27, 2013 at 3:10

You use DDR3-2957MHz with Timings 9-9-9-24. You overclocked the RAM too MUCH! Change this in the BIOS/UEFI and go back to DDR3-1333MHz or 1600MHz if your RAM is able to handle DDR 1600MHz.

Now run memtest86+ again. If you still get error, test each RAM module its own (remove the other modules from the laptop) until you found the damaged RAM and replace it with a new one.

  • I am not overclocking my RAM, at least not willingly. My bios is set on default factory settings. I'll try what you said. Mar 27, 2013 at 13:08
  • I've actually had similar issues with memtest86+ not reading the SPD data correctly, as in the first image on this question (no, I wasn't overclocking my RAM, and definitely not at 4123MHz! [btw, the DDR3-2957 in this question means 1478 MHz; Double Data Rate RAM's number is double that of the clock rate]). Reseating helped in my case.
    – Bob
    Jul 14, 2014 at 9:57

I have a similar problem, memtest in my case reports a size o 7879M against the 8192M I expected and the fault happens at the address 8406.02M. I have random application crashes in Ubuntu, but the system does not crash usually.

I simply set the in the kernel boot parameter the value: mem=7500M and this solved the problem of random crashes.

To be precise I have set it in the file /etc/default/grub the variable


and later issued a sudo update-grub.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.