I just installed git using cygwin. I then tried using git help status but I received the error fatal: '/usr/share/doc/git-doc': not a documentation directory. And indeed, there is no folder git-doc in /usr/share.

What do I need to do to get the documentation ? Did the installation go wrong, did I forget to install a package ?



The Cygwin git package is indeed missing the HTML documentation. This was probably missed because of a disparity in the upstream build system: while make doc creates both the man pages and HTML, make install-doc only installs the man pages; a separate make install-html is necessary. I'll try to get this fixed in the Cygwin distribution.


According to the git wiki, you should do this:

Getting and installing documentation

You can find all the plain text documentation in the Git source tree's Documentation/ directory.

In order to build the HTML version of the documentation you need to have AsciiDoc version 7.0 or greater installed. Man pages also require that xmlto is installed.

To build and install documentation from the Git source code simply run:

$ make install-doc
  • I tried adding the asciidoc and xmlto packages (which I found in the repos), but the doc is still not there. I don't understand what make install-doc means. Should I just type it in the terminal ? From which directory ? make is not installed, should I install it ? – Car981 Mar 27 '13 at 19:17
  • I am not sure since I am not on windows/cygwin. I understand that you should open a terminal, cd into wherever you have downloaded the git sources and run the command make install-doc from the terminal. – terdon Mar 27 '13 at 19:23
  • Okay I think it works now (I manually downloaded the site). However I am redirected to a console-like browser (w3m.exe). I tried setting the value git config --global web.browser firefox, and even git config --global browser.firefox.path "C:\Program Files\Mozilla Firefox\firefox.exe", but it doesn't work. What should I do to run the html with firefox ? – Car981 Mar 27 '13 at 19:37
  • Umm, browse to the file using a file manager and double click? – terdon Mar 27 '13 at 19:38
  • Yes sure but I'm looking for a fix, not a work around :). I could also just google for git help status, but that's not what I'm looking for. – Car981 Mar 28 '13 at 17:23

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.