I have a Dell Vostro 3555 and recently I noticed that my battery is not charging at all. I see this message when I boot up the computer:

The AC power adapter type cannot be determined. You system will operate slower and the battery will not charge.

Please connect a Dell 65 W AC adapter or higher for best system operation. To resolve this issue, try to reseat the power adapter."

The laptop runs fine on AC power but doesn't charge the battery. I have tried the following after reading others with similar problems:

1) Disconnect AC

2) Shutdown

3) Remove battery

4) Connect AC

5) Startup

6) Under the Batteries category (in Device Manager), right-click the Microsoft ACPI Compliant Control Method Battery listing, and select Uninstall. Do this for each instance (I had 2 batteries installed, so 2 instances. Most users will only have 1).

7) Shutdown

8) Disconnect AC

9) Insert battery

10) Connect AC

11) Startup

This did not work then I found this question that was the same problem (different model) and it most likely was a hardware issue since the message appears when booting up.

This leads me to a few questions:

  1. Is this a hardware issue?
  2. If it is a hardware issue is there a way to override the warning and charge the battery anyway?
  3. If possible to override the warning and charge anyway is this safe (or smart)?

Note: I do not have a second Power Unit to try but I do not believe this is the issue as this power unit is fairly new (I replaced the original about 3-4 months ago).

3 Answers 3


It sounds to me exactly like the warning says - the power unit is an after-market unit without the logic circuitry confirming its a Dell Unit, and possibly underspecced.

Coincidentally one of my co-workers gets this message on her [Dell] laptop (and asked me about it today), however her laptop charges fine, so its probably that their is not enough power. (ie the warning does not prevent charging, only warns that it might not charge, so to override it you just press "F1" and continue as normal).

  • 3
    If you are using a Dell-branded charger, and the right one for that system, then either the charger is defective or the charging port may be partially pulled of the motherboard and causing the system to be unable to detect the type of charger.
    – LawrenceC
    Mar 28, 2013 at 2:57
  • Quite right - I'm pretty sure it is a charger from amuch older model Dell - same power output though.
    – davidgo
    Mar 28, 2013 at 5:38
  • @ultrasawblade - The charger I have is a Dell Made Charger for this Model of Laptop. Has worked fine until this issue cropped up past couple days. I guess I try another charger then if that doesn't work off to the shop it goes =< Thank You davidgo and ultrasawblade for the help!
    – L84
    Mar 28, 2013 at 6:01

Try wiggling the power cord around a bit and see if there is a connection detected. This worked for me at least temporarily.


Dell power cords are your trouble. The wire breaks off to the center pin and without that the PC will power up but the battery will not charge. You can take it apart at the plug nearest the PC and solder it back together, but good luck. You have to cut the thing apart with a blade. I have several Dell and they all have that problem.

Order a new one and be very careful not to bend it ever again. Center pin should have +16 volts and the Neg. is the inside rim of the plug. The outside should read +18 volts.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .