Minecraft, a Java client application, is frequently losing connection with the message "Internal exception: java.net.SocketException: Software caused connection abort: socket write error" or the message "Internal exception: java.net.SocketException: Software caused connection about: recv failed".

These are the troubleshooting steps that I have tried and their results:

  • Is minecraft up to date? Update to 1.5 (now to 1.5.1): same error
  • Is my Windows 7 system up to date? Window update, all optional packages installed: same error
  • Is it the server? Connect to another server: same error
  • Is it me? Connect to same server from work: no error!
  • Is it my connection? Normal internet use with Chrome/Fx: no error
  • Is it streaming connections? Long time ssh (putty): no error
  • Is my Java out of data? Updated: same error
  • Should I be using 64 bit Java instead? Installed: same error
  • Maybe 32 bit Java is interfering?
    • Manual launch with full path: same error
    • uninstall 32 bit Java: same error
  • Maybe is should be using 32 bit Java instead? same as above: same error
  • Well - I noticed "Native Method" as the root of the Exception in Java - maybe my drivers? Updated: same error
  • Are the local Minecraft files corrupted? Deleted .minecraft (and restored after): same error
  • Is it my software firewall (Windows built in)? Disabled: same error
  • Is it my antivirus (Windows Defender)? Disabled - with and without firewall: same error
  • If I watch my NIC with Wireshark will I notice anything that might disrupt my stream? Ran wireshark a few times with the connection breaking: no obvious pattern
  • Does my ISP has something against Minecraft for some reason (reaching by now)? Called: They don't do application or port filtering like that
  • My motherboard has problems anyway, maybe if I replace it (different NIC)? Replaced: same error
  • Okay, connect through completely different equipment, to different ISP? Used a different connection, router instead of 1U switch, different ISP, technology, etc (same cable, didn't dig a new one out of storage, but I doubt that's the problem): same error
  • What about a server on (localhost)? Hosted: no error!
  • What if I connect to the localhost server using my public IP? same error!

I am reasonably confident by now that it is related to my system in some way, and not the network, network equipment, or remote server. There is no router or hardware firewall, or any NAT device of any type between me and the internet - were there, that would have been among my first troubleshooting attempts.

What else should I try to diagnose this error? The last two steps seem particularly revealing, but I'm not certain where to go from there.

Edit: so, I installed Cygwin and tried mkfifo backpipe; nc -l 25565 0< backpipe | tee mc.log | nc <server> 25565 1> backpipe from my work box, where it worked, and on my home box, where I instead get "Connection Lost: End of Stream" - fundamentally the same error again.

  • Checked with server op - no firewalls running on his end
  • I feel this to be a useful question due to the discussions I've seen about it via Google searches, which would indicate that it is not unique, and the dearth of useful answers in other locations. – Iiridayn Mar 28 '13 at 6:29
  • sorry I misread I thought it was ok with both local link and your public IP. – Not Kyle stop stalking me Mar 28 '13 at 18:10

Remark: The test using the public IP is not conclusive since normally one cannot self-connect through the router.

It might be worthwhile testing another computer at your home with a first-time installation of java and Minecraft.

Question: Is your Minecraft server in the same country as you ? It might be useful to test with different countries, or using Pingtest.net.

I'm suggesting this because I suspect the Minecraft client (or even Java) of badly handling lags, doing a premature timeout and then making no attempt to reconnect.

In the meantime, the Auto-Reconnect plugin might simplify quickly getting over the error.

A good test to find if the lag problem is caused by an installed product, is to boot into Safe Mode with Network (if the generic display is acceptable with Minecraft). In this mode, no non-Microsoft product can cause lag problems.

The most frequent kind of problematic products that can introduce lags are security suites or parental control products. In the case of the poster, the culprit was K9.

  • There is no router involved until in the ISP office. Minecraft server is in the same state as me - less than 100 miles away. I'll check out the Auto-Reconnect plugin. – Iiridayn Apr 12 '13 at 15:26
  • Tried to install the Auto-Reconnect plugin, which told me to install another mod first, which threw an Invalid signature file exception. Personally not a big fan of patching jars or binaries in general - unless I'm prepared to spend a long time dinking with it. Since Minecraft is already not working correctly, I am especially uncomfortable with the thought of adding complexity to the problem. – Iiridayn Apr 13 '13 at 0:40
  • Borrowed my roommate's computer, plugged it into my network connection, installed Minecraft - works fine. Same cable, same networking equipment - at this point clearly a software problem. – Iiridayn Apr 13 '13 at 19:08
  • I suggest then to uninstall the Minecraft client, then Java, clean up all their folders, ensure that you have the latest version of each, and reinstall. – harrymc Apr 13 '13 at 21:11
  • 1
    I'm going to accept this one - so please update your answer with this solution. In order to go online in Safe Mode I had to uninstall Bluecoat K9 from my computer. I've do so while troubleshooting several times, but never quite correctly (with a proper reboot without reinstalling, etc), and uninstalled it for real. Upon rebooting properly, I figured I'd just test it first... Problem went away. K9 must be introducing just enough latency only when I don't move - thank you very much for all your help. I believe that this will be a useful thing to check for the Minecraft community going forward. – Iiridayn Apr 15 '13 at 6:14

Download the minecraft.jar from minecraft's site, here:


Put it in a folder where you can access it easily. In the same folder, right click inside, choose New -> Text document. Double click to open up the text document in notepad, paste these two lines in:

java -Xmx256M -Xms256M -cp minecraft.jar net.minecraft.LauncherFrame


Go up to File -> Save as, change the file type to "All files" and save the file name to anything that ends with .bat, e.g. Run.bat. Run the .bat file by double clicking on it.

  • Though it looked about the same as the manual launch that I did above, I tried this, to the same effect. – Iiridayn Apr 13 '13 at 0:18

Try this:

Go To Control Panel->Java->General tab->Network Settings ...->and make sure that Direct Connection is enabled.

Also, while you are there, try to mess around with the Security Settings under the Security tab and the Advanced settings under the Advanced tab.

Good luck.

  • Changing to Direct Connection made no difference - this is probably because it was on Use browser settings, which itself is on direct connection. Good thought though. – Iiridayn Apr 15 '13 at 5:41
  • That is so bizarre ... I had the same exact thing happen to me, and that was my fix ... sorry I couldn't be of more help – Dima Apr 15 '13 at 6:33

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.